Hello

I have 6 server with QT.
All work well. However, I had to turn off DK on one.

The server sometimes had an email for multiple recipients had a problem.

"qmail-dk: Cannot sign message due to invalid message syntax. (#5.3.0)"

I do not know where the problem is, I do not care.

Version package:
[root@mail ~]# rpm -qa  | grep qt
maildrop-2.9.1-2.qt.el7.x86_64
dovecot-2.2.29.1-19.qt.el7.x86_64
libsrs2-1.0.18-0.qt.el7.x86_64
vpopmail-5.4.33-1.qt.el7.x86_64
control-panel-0.5.1-1.qt.el7.x86_64
squirrelmail-1.4.22-1.qt.el7.x86_64
ezmlm-cgi-0.53.324-0.qt.el7.x86_64
qmailmrtg-4.2-3.qt.el7.x86_64
clamav-0.99.3-2.qt.el7.x86_64
qmt-release-1-4.qt.el7.noarch
mailman-2.1.12-20.qt.el7.x86_64
mailman-debuginfo-2.1.12-20.qt.el7.x86_64
qmail-1.03-2.1.qt.el7.x86_64
qmailadmin-1.2.16-2.qt.el7.x86_64
libsrs2-devel-1.0.18-0.qt.el7.x86_64
daemontools-0.76-0.qt.el7.x86_64
autorespond-2.0.5-0.qt.el7.x86_64
vqadmin-2.3.7-1.qt.el7.x86_64
ezmlm-0.53.324-0.qt.el7.x86_64
maildrop-devel-2.9.1-2.qt.el7.x86_64
spamdyke-5.0.1-0.qt.el7.x86_64
ucspi-tcp-0.88-0.qt.el7.x86_64
ripmime-1.4.0.10-0.qt.el7.x86_64
spamassassin-3.4.1-1.qt.el7.x86_64
simscan-1.4.0-1.qt.el7.x86_64
isoqlog-2.2.1-2.qt.el7.x86_64
[root@mail ~]#


Havrla



Dne 1.2.2018 v 10:33 Remo Mattei napsal(a):
I just tested mine yum upgrade no new pkg and sent an email out it works ok.

Inviato da iPhone

Il giorno 01 feb 2018, alle ore 07:25, Chandran Manikandan <tech2m...@gmail.com <mailto:tech2m...@gmail.com>> ha scritto:

Hi Eric,

Am currently using COS 6 with domainkeys and tcp file like that QMAILQUEUE="/var/qmail/bin/simscan"

There is no issue for send and receive.

Do i need to use to update of your above email steps?



On Thu, Feb 1, 2018 at 1:43 PM, Eric Broch <ebr...@whitehorsetc.com <mailto:ebr...@whitehorsetc.com>> wrote:

    Hello list,

    If anyone has upgraded qmail lately, especially those of you who
    DO NOT use domainkeys and those who DO use dkim, remember that an
    upgrade overwrites the qmail binaries (/var/qmail/bin). This
    could affect domainkeys, which you really shouldn't use anymore
    IMHO, and DKIM signing.

    1) Domainkeys: If you DON'T use domainkeys and you've upgrade you
    might have to unlink qmail-queue from qmail-dk and link (ln -s)
    it to qmail-queue.orig. Another approach is to simply change
    QMAILQUEUE in /etc/tcprules.d/tcp.smtp (below).

    QMAILQUEUE="/var/qmail/bin/qmail-queue.orig"


    2) DKIM: On upgrade the perl script 'qmail-remote' which calls
    'qmail-remote.orig', will be overwritten...run the following commands

    #   wget -O /var/qmail/bin/qmail-remote
    https://raw.githubusercontent.com/qmtoaster/dkim/master/qmail-remote
    <https://raw.githubusercontent.com/qmtoaster/dkim/master/qmail-remote>

    # chown root:qmail /var/qmail/bin/qmail-remote

    # chmod 777 /var/qmail/bin/qmail-remote

    Sorry about the inconvenience.

    Comments and suggestions please!

-- Eric Broch
    White Horse Technical Consulting (WHTC)


    ---------------------------------------------------------------------
    To unsubscribe, e-mail:
    qmailtoaster-list-unsubscr...@qmailtoaster.com
    <mailto:qmailtoaster-list-unsubscr...@qmailtoaster.com>
    For additional commands, e-mail:
    qmailtoaster-list-h...@qmailtoaster.com
    <mailto:qmailtoaster-list-h...@qmailtoaster.com>




--
*Thanks,*
*Manikandan.C*
*System Administrator*


Reply via email to