If I use port 25 the servers returns "421: Refused. You have no DNS reverse entry".

I guess it's still ignoring my rules in tcp.smtp.cdb file.

Could it be because I installed the qmail-1.03-3.1 from development version?

Em 18/07/2019 13:41, Eric Broch escreveu:

Why don't you use port 25?

On 7/18/2019 8:22 AM, Leonardo Porto wrote:


The first client is an APC Automatic Transfer Switch, it has no SMTP authentication method so I configured relay and it was able to send us notification messages in the old server, not anymore in the new one.

The second client is a PC using Outlook Express, it has no STARTTLS support and its SSL method doesn't work, so I want to configure relay for it. I tried "my server requires authentication" (Server tab) option enabled and disabled, I tried "This /server requires/ a /secure connection/ (/SSL/)" (Advanced tab) also, both without success.


Em 18/07/2019 10:58, Eric Broch escreveu:

Are you authorizing with the client?

On 7/18/2019 7:51 AM, Leonardo Porto wrote:

Hi everyone,

My relay rules on tcp.smtp.cdb are not working after I installed a new server.

Here is my /etc/tcprules.d/tcp.smtp:


First line is the original from toaster installation, the other three lines I included the same way they were in the old server and I generated a new cdb file using "qmailctl cdb" command.

My /var/qmail/supervise/submission/run:

QMAILDUID=`id -u vpopmail`
NOFILESGID=`id -g vpopmail`
MAXSMTPD=`cat /var/qmail/control/concurrencyincoming`
export SMTPAUTH="!"

exec /usr/bin/softlimit -m 128000000 \
    /usr/bin/tcpserver -v -R -H -l $HOSTNAME -x $TCP_CDB -c "$MAXSMTPD" \
    -u "$QMAILDUID" -g "$NOFILESGID" 0 587 \
    $SMTPD $VCHKPW /bin/true 2>&1

But I still can't relay from those two clients throught port 587, the server asks for authentication. Any clues?

Reply via email to