William Fisher:
> Hi,
> My name is William Fisher, and I built a desktop specifically for Qubes Os.
> I have one Samsung M.2 NVMe SSD and one 1TB disk drive. After I install
> Qubes to the SSD and reboot, it does not recognize the SSD as a bootable
> device. Using the same install procedures on the HDD, everything works
> fine. When using Qubes from the HDD to access the SSD, the BOOT file is
> empty, so there are no files to rename as you've directed in the UEFI
> troubleshooting. Also, I cannot access the /BOOT/EFI/ file on my HDD, it
> says I don't have the required permissions. On install, I set up a password
> for the root user, but cannot act as the root user, even through terminal.
> There is no prompt for a password.
> Also, I've tried to use a 4K monitor with Qubes, but the max resolution
> option is 1080p. I understand that there is a way to create custom
> resolution options through terminal using xrandr, but have tried and it
> failed when using addmode eDPI 2560x1600 (I was trying this resolution
> first as someone in an email string did this successfully).
> Any help would be greatly appreciated, especially the the boot issues. I
> would prefer not booting Qubes off my HDD when I got an M.2 SSD
> specifically for Qubes.
> Thank you,
> William fisher

First, make sure your motherboard (UEFI) even supports booting from a
PCIe device. I don't have any PCIe SSDs so I don't know if it's common
for UEFI implementations to support booting from PCIe or not, and you
didn't mention what motherboard you have. Just covering all bases.

I'm just sort of guessing here, but try copying the /boot/efi directory
from the HDD to the SSD, then see if it'll boot from the SSD. You'll
have to mount the SSD's EFI boot partition somewhere first of course. If
it still won't boot from the SSD, try renaming the files as described in
the UEFI troubleshooting page.

You say it won't prompt for the root password. What output do you get
from the sudo command? If you can't get that to work, boot into the
Qubes installation media and use Ctrl+Alt+2 to switch to tty2 which
should have a root(able) shell on it.

If all else fails, try unplugging the HDD and reinstall Qubes, and if it
successfully boots, plug the HDD back in. It's unlikely but possible
that either the installer or the UEFI got confused about which device to
boot from. This is a shot in the dark, probably won't work, will take
some time, and will wear the SSD a little so use it as a last resort.

As for the xrandr issue, you might want to start a new thread with an
appropriate title if no one replies to it here.


ONLY AT VFEmail! - Use our Metadata Mitigator to keep your email out of the 
NSA's hands!
$24.95 ONETIME Lifetime accounts with Privacy Features!  
15GB disk! No bandwidth quotas!
Commercial and Bulk Mail Options!  

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to