On Monday, October 2, 2017 at 11:06:38 AM UTC, beso wrote:
> On Monday, October 2, 2017 at 12:01:41 AM UTC+3, One7two99 wrote:
> > Hello Beso,
> > 
> > > Mobile Broadband is enabled in 
> > > NetworkManager Applet. 
> > > I can create new Mobile Broadband 
> > > connection but it keeps connecting 
> > > and nothing else
> > 
> >  I am using mobile broadband within Qubes and am happy to help, but 
> > honestly your question/problem is to unqualified. 
> > 
> > - what version of Qubes are you running?
> > - what modell of mobile broadband card are you using? 
> > - how is the broadband card connected? Probably as an internal USB device. 
> > - are you using sys-usb to connect the card to your sys-net VM? Or are you 
> > passing through the whole USB controller?
> > - have you tried to boot up a Fedora live Linux and check if your mobile 
> > broadband is working there?
> > - what does "keeps connecting" means?
> > 
> > My suggestion:
> > Try to get the mobile broadband card working without Qubes (Linux Live Boot 
> > from USB-Stick).
> > If you got it working try to make it work in Qubes.
> > 
> > [799]
> - Laptop is ThinkPad X1 Carbon 4th gen.
> - Qubes release 3.2(R3.2)
> - Previous linux distros worked (ubuntu 16.04)
> - from qvm-usb I can see that card is: Sierra Wireless Incorporated Sierra 
> Wireless EM7455 Qualcomm Snapdragon X7
> - do I have to attach it somewhere?
> - As I mentioned I can create new broadband connection and even select it 
> from applet menu but it keeps connecting(applet shows "circles" as trying 
> connect).
> I am trying to make screenshot if it helps

Yes, because you passed the USB controller to your sys-USB, correct? In that 
case, that means if you attach an USB modem, it'll be passed to your sys-USB, 
and not your sys-net that should have the internet device instead. 

The solution could be to merge your sys-net with sys-usb, though, I never felt 
truly safe having my USB exposed like that. Though logically speaking, its not 
anymore exposed in sys-net, than compared with any other non Qubes-OS system 
out there. Either way, I believe this is pretty likely your problem.

Try test it first, you can worry about the security after wards.
See if it works if you passthrough your USB controller to your sys-net instead, 
and then try apply your USB modem there. 

If it still doesn't work, then it's probably either (in order of likelihood, 
the first is most likely imho).

- No driver/module for your USB modem. It may be visible in i.e. "lspci", but 
it'll have no functionality, no less any signal.
- PCI strictness is too strict, and qvm-prefs strictreset option set to false 
is not enough.
- Pass-through is not supported in your USB modem.

But these potential issues, you only need to worry about, after you get USB 
into sys-net, instead of sys-usb.

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to