On Tue, Dec 08, 2020 at 10:22:17PM +0000, 'awokd' via qubes-users wrote: > 
Ulrich Windl:
> > Hi!
> > 
> > Trying to get my WLAN adapter into sys-net, I made a fatal mistake: The USB 
> > host added also has the boot device (and mouse) connected. Now as soon as 
> > sys-net starts (maybe even earlier) the PV for qubes becomes inaccessible.
> > 
> > Mounting the device in another Linux system, I tried to prevent the start 
> > of sys-net by renaming the systemd link for multi-user target, but that did 
> > not help.  The kernel panics shortly after boot.
> > Before I had tried to find (and edit) the settings that cause the problem, 
> > but could not find them.
> > 
> > My idea was to prevent start of sys-net, then use the qubes manager to undo 
> > my bad setting.
> > Unfortunately I don't get that far.
> Try
> https://github.com/QubesOS/qubes-issues/issues/2270#issuecomment-242900312
> first. If that doesn't work, make a copy of /var/lib/qubes/qubes.xml, and
> edit it by hand to remove autostarting sys-net (and all other autostarts
> that depend on it such as sys-firewall), and/or remove the WLAN binding to
> sys-net. It's XML so a somewhat fragile file; pay attention to the <>/ etc.

I wouldn't change too much in that file, just the absolute minimum.
To edit the xml file and remove the devices assigned to sys-net, look
for lines like <device backend-domain="dom0" id="xxxxxx"/> in the
sys-net section - delete those lines.
MAKE SURE you have a copy of that file somewhere safe before editing.

Then restart - sys-net should start but wont be stealing the usb

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 

Reply via email to