Did you read the bug report from three weeks ago and the suggested fix documented on the webpage you cited?
— David Sent from my iPhone > On Jul 10, 2019, at 1:09 PM, Patrick (Malone Quantitative) > <[email protected]> wrote: > > First response: The ID column in your data is labeled "eid" but your > function call refers to "id". > > >> On Wed, Jul 10, 2019 at 1:38 PM Ana Marija <[email protected]> >> wrote: >> >> Hello, >> >> I am trying to use this program: >> https://github.com/kenhanscombe/ukbtools >> >>> my_ukb_data[1:3,1:3] >> eid sex_f31_0_0 year_of_birth_f34_0_0 >> 1 1000017 Female 1938 >> 2 1000025 Female 1951 >> 3 1000038 Male 1961 >> >>> ukb_icd_diagnosis(my_ukb_data, id = "1000017", icd.version = 10) >> Error: Column 1 must be named. >> Use .name_repair to specify repair. >> Call `rlang::last_error()` to see a backtrace >> >> Function is described here: >> https://kenhanscombe.github.io/ukbtools/reference/ukb_icd_diagnosis.html >> >> I run it on: >> >> $platform >> [1] "x86_64-pc-linux-gnu" >> $arch >> [1] "x86_64" >> $version.string >> [1] "R version 3.5.0 (2018-04-23)" >> >> Would anyone know why this is happening? >> >> Thanks! >> >> [[alternative HTML version deleted]] >> >> ______________________________________________ >> [email protected] mailing list -- To UNSUBSCRIBE and more, see >> https://stat.ethz.ch/mailman/listinfo/r-help >> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html >> and provide commented, minimal, self-contained, reproducible code. > > ______________________________________________ > [email protected] mailing list -- To UNSUBSCRIBE and more, see > https://stat.ethz.ch/mailman/listinfo/r-help > PLEASE do read the posting guide http://www.R-project.org/posting-guide.html > and provide commented, minimal, self-contained, reproducible code. ______________________________________________ [email protected] mailing list -- To UNSUBSCRIBE and more, see https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code.

