Hey everyone,

I'm not sure what to do here. I'm trying to install plai-typed with raco:

vishal@witters:~/programming_misc/plangs$ sudo raco pkg install -i plai-
> typed
> Resolving "plai-typed" via http:
> //download.racket-lang.org/releases/6.3/catalog/
> Resolving "plai-typed" via http://pkgs.racket-lang.org
> Using cached15130507731513050773990 for github:
> //github.com/mflatt/plai-typed/master
> The following out-of-date packages are listed as dependencies of plai-
> typed:
>    scribble-lib (have 1.12, need 1.16)
> Would you like to update these dependencies? [Y/n/a/c/?]
After trying to install, raco fails to find the appropriate version of 

Would you like to update these dependencies? [Y/n/a/c/?] Y
Resolving "scribble-lib" via http:
Resolving "scribble-html-lib" via http:
Using cached15130508571513050857401 for http:
raco pkg install: version mismatch for dependency
  for package: plai-typed
  mismatch packages:
   scribble-lib (have 1.12, need 1.16)

Trying to update scribble-lib directly doesn't help:

vishal@witters:~/programming_misc/plangs$ sudo raco pkg update scribble-lib
Inferred package scope: installation
Resolving "scribble-lib" via http:
Resolving "scribble-html-lib" via http:
No updates available

It can't find anything beyond 1.12, even though the project is currently on 
version 1.26 

What's the best way around this? Why isn't raco finding the appropriate 
versions? If I cloned the latest release and tried to install from that, 
would raco's package version/checksums be updated appropriately?

You received this message because you are subscribed to the Google Groups 
"Racket Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to racket-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to