I forgot to mention that I have a 4K display, and I think that's important 
to note here.

On Friday, February 9, 2018 at 7:00:18 PM UTC-10, Evan Whitmer wrote:
> I, too, am having typing latency issues in DrRacket in the definitions 
> window. As Dave noted, the size of the window seems to be related to the 
> issue, and, in my experience, it's not just an issue with the Definitions 
> window. Both the Interactions window and even the following code snippet 
> (taken from StackOverflow 
> <https://stackoverflow.com/questions/37583997/basic-code-editor-functionality-in-racket>)
> will have this same lag:
> (define frame (new frame% [label "Simple Edit"]
>                    [width 1800]
>                    [height 1800]))
> (define canvas (new editor-canvas% [parent frame]))
> (define text (new text%))
> (send canvas set-editor text)
> (send frame show #t)
> (define delta (make-object style-delta% 'change-size 14))
> (send delta set-face "Menlo")
> (send text change-style delta)
> I am on Ubuntu 17.10 using Racket 6.11 with the proprietary nVidia drivers 
> and X.org. My GTK version is 3. I don't have this issue with any of the 
> other text editors that I've tried to use.
> I tried to profile the above text editor, but I am a novice Racketeer and 
> could not figure out a way to profile a thread managed in racket/gui. Does 
> anyone perhaps know of a way to hook the above into a profiler to see what 
> might be the cause of this lag?
> Has anyone happened to stumble onto this issue recently and solved it?
> Evan
> On Saturday, April 1, 2017 at 6:07:28 AM UTC-10, gneuner2 wrote:
>> On Fri, 31 Mar 2017 13:34:38 -0700 (PDT), Dave Musicant 
>> <musi...@gmail.com> wrote: 
>> >I'm using DrRacket on a 64-bit Ubuntu 16.04 system with the 
>> >default Unity windowing system, and am finding that typing 
>> >in the definitions window is laggy. 
>> I've seen similar behavior on CentOS 6.5-6.8 under Gnome(2) - it has 
>> persisted across a number of OS and Racket versions.   
>> I have seen the lag in Dr Racket with 6.1, 6.5, 6.7 and 6.8.  I 
>> compiled 6.1 and 6.5 myself, so there might have been something 
>> strange in those cases, but 6.7 and 6.8 were stock Linux x86_64 
>> downloads. 
>> Turning off background expansion helps somewhat, but I have found that 
>> limiting memory seems to help the most.  On Linux I run Dr Racket with 
>> the limit set to 512MB.  That might be too low for some people, but it 
>> works fine for my typical (webserver app) uses. 
>> George 

You received this message because you are subscribed to the Google Groups 
"Racket Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to racket-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to