I've been having trouble getting the gallery extension working. This is a brand new install, so perhaps it's a version compatibility issue.

After following the installation instructions, and creating my first gallery, I tried uploading a single image (JPG). I got the following error:


The error occurred while evaluating nil.gallery_id=):
    /vendor/extensions/gallery/app/models/gallery_item.rb:39

Here's the code in app/models/gallery_item.rb:38-40:

  before_thumbnail_saved do |item, thumbnail|
    thumbnail.gallery_id = item.gallery_id
  end


So, thumbnail is assigned nil. I checked attachment_fu and it seems like it only expects a single argument to the block (thumbnail). I tried all sorts of alternative ways of hooking this in and failed. Oddly enough, even the debugger got sick (with a stack error). Eventually I simply commented out the line and tried again -- surprisingly, everything seems to work (even with gallery_id set to nil for the thumbnail items)!

Any ideas? I'm a little nervous about commenting out code when I don't know what it's for. Alternatively, less code is better :-)

Aloha a hui hou,
Ken
--
Ken Mayer / [EMAIL PROTECTED] / 808-722-6142 / http://www.bitwrangler.com/


_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to