Jim - thanks for the input, if I end up needing that functionality on
my current project I'll dig further (initial investigation in the
thread below)..

----------------------------------------------
http://cenatus.org/
http://radialsolutions.co.uk/
----------------------------------------------



On Thu, Jun 3, 2010 at 9:51 PM, Jim Gay <j...@saturnflyer.com> wrote:
> Sorry guys (I didn't move into this google group when the change was
> made, so I never saw these emails). I've seen this error too and plan
> to fix it. If I recall, it stems from some call to ".all" on what it
> expects to be an active record collection, but it's actually an array.
>
> On Jun 1, 8:23 am, Matt Spendlove <matt.spendl...@gmail.com> wrote:
>> Could any of the devs help us out here please?
>>
>> Thanks.
>>
>> On May 27, 6:43 pm, Matt Spendlove <matt.spendl...@gmail.com> wrote:
>>
>>
>>
>> > Initial install of 0.9RC2 does this for me with selection of "styled
>> > blog" template. Any thoughts?
>> > I don't know the code well enough but this is the triggering line from
>> > standard_tags.rb:
>>
>> > displayed_children = paging ? tag.locals.options.merge(paging)) :
>> > tag.locals.children.all(options)
>>
>> > I ran up the blog in dev mode and we can see: "undefined method `all'
>> > for #<ArchiveFinder:0x1033a9798>". Should this class implement "all"?
>> > Had a scan through the commits on GitHub but couldn't see anything,
>> > not sure how I find theArchivesubmodule anyway?
>>
>> > Input appreciated :)
>>
>> > Matt
>>
>> > On May 27, 2:51 am, Christian <neo...@gmail.com> wrote:
>>
>> > > Got the same problem. Anyone solve it?
>>
>> > > Thnkx,
>> > > Christian
>>
>> > > On May 21, 3:06 am, Joseph Ridgway <jos...@comsoft155.com> wrote:
>>
>> > > > I have this same issue. What's up? Anyone figure it out?
>>
>> > > > Thanks,
>> > > > Joe
>>
>> > > > On Apr 27, 10:27 am, Si Forster <m...@siforster.net> wrote:
>>
>> > > > > Me again!
>>
>> > > > > I've implemented the simple blog idea (seen 
>> > > > > here:http://wiki.github.com/radiant/radiant/using-radiant-as-a-blog) 
>> > > > > and
>> > > > > encountered a problem withArchiveMonthIndex.
>>
>> > > > > Setting theArchiveMonthIndexbody as:
>>
>> > > > > <r:archive:children:each order="asc">
>> > > > > <div class="entry">
>> > > > >   <h3><r:link /></h3>
>> > > > >   <r:content />
>> > > > >   <r:if_content part="extended"><r:link
>> > > > > anchor="extended">more&#8230;</r:link></r:if_content>
>> > > > >   <p class="info">Posted by <r:author /> on <r:date format="%d %b 
>> > > > > %Y" /></p>
>> > > > > </div>
>> > > > > </r:archive:children:each>
>>
>> > > > > Results in the error:
>>
>> > > > > *undefinedmethod`all' for #
>>
>> > > > > *when viewing the front end version of a monthlyarchivepage
>>
>> > > > > Anyone else had this problem?
>>
>> > > > > Si
>> > > > > _______________________________________________
>> > > > > Radiant mailing list
>> > > > > Post: radi...@radiantcms.org
>> > > > > Search:http://radiantcms.org/mailing-list/search/
>> > > > > List Site:http://lists.radiantcms.org/mailman/listinfo/radiant
>> > > > > Radiant:http://radiantcms.org
>> > > > > Extensions:http://ext.radiantcms.org
>>
>> > > > > --
>> > > > > Subscription 
>> > > > > settings:http://groups.google.com/group/radiantcms/subscribe?hl=en

Reply via email to