On 3 June 2010 05:16, john muhl <johnm...@gmail.com> wrote:
> On 02 Jun 2010, at 3:06 PM, trans wrote:
>
>> Can anyone fill me in on the fix?
>>
>>  tr...@logisys:radiant$ rake production db:bootstrap
>>  (in /home/trans/Company/PsyTech/jobs/sunventures/radiant)
>>  rake aborted!
>>  can't activate rack (~> 1.0.0, runtime) for [], already activated
>> rack-1.1.0 for ["radiant-0.8.2"]
>
> it's a well known issue (with rails i think) and usually the simplest fix is 
> to uninstall rack 1.1.0 and install 1.0.1. i believe there was a commit 
> recently that fixes this on master so at least 0.9 when its released won't 
> suffer from this.

But with pre-0.9, you can fix the radiant gem spec:

<your ruby installation>/gems/1.8/specifications/radiant-0.8.2.gemspec

Change the line:

      s.add_runtime_dependency(%q<rack>, [">= 1.0.0"])

to:

      s.add_runtime_dependency(%q<rack>, [">= 1.0.0","< 1.1.0"])

This did the trick for me. I can't uninstall rack 1.1.0 as I need it
for another Rails app.

Ringo

Reply via email to