Additional anecdotal stuff:

I moved my Radiant app. to use bundler for gem management today.

I run Radiant in a standard Rails app. out of vendor/radiant. I followed these instructions for running bundler with Rails 2.3.x: http://gembundler.com/rails23.html

I was able to remove all of the config.gem lines from my RAILS_ROOT/environment.rb. The only problem that I had was RADIANT_ROOT/app/models/standard_tags.rb would fail to load because of its dependency on will_paginate. I had to add a require 'will_paginate' to the top of that file to get the app. to work.

Wes

On 9/8/10 8:00 AM, Jim Gay wrote:
Yes.
There is a Rails 3 branch http://github.com/radiant/radiant/tree/rails3

I'm gearing up to dive in to that, but any help would be appreciated.
We'll probably do another release with 2.3.9 and then Rails 3. It will include 
serious and breaking changes to the entire system.

On Sep 8, 2010, at 8:38 AM, Bermon wrote:

I'm actually looking for the same answer. Wondering if Rails 3 support
is in the near future and if there's anything that we can do to help
out.

On Sep 6, 2:26 pm, Wes Gamble<we...@att.net>  wrote:
   Anecdotally...

I'm running my Radiant app. under Rails 2.3.9 and it seems to be working
fine - lots of deprecation warnings about

   ActiveSupport::Dependencies.load_once_paths is deprecated

   ActiveSupport::Dependencies.load_paths

but nothing seems to have broken so far.

What is the best guess for when Radiant will support using Rails 3?

Thanks,
Wes

Reply via email to