Haselwanter Edmund said the following on 09/10/2010 08:48 AM:
> On 10.09.2010, at 14:03, Anton J Aylward wrote:
>> Haselwanter Edmund said the following on 09/10/2010 07:35 AM:
>>> you did not answer my questions:
>>> what does (on the terminal)
>>> $ gem env 
>> I did that.
>> My thread was about problems with being unable to start after a
>> Dreamhost upgrade to 64-bit and a conversion to RedCloth-4.2.3
> maybe a 64 / 32 bit problem? I don't know about Dreamhost upgrades. Did you 
> do a update or a new install?
> If its a update with the same storage you might need to re-install your gems 
> (as native extensions are compiled for the platform ...)

In that the compiled component of RedCloth had been compiled for 32-bit,
yes.  But as I said in my post, I reinstalled the gem and recompiled.
And updated the gems.  Go re-read all the details in the archives.

>>> output look like? 
>>> $ gem list
>>> output look like? 
>>> can you start irb and require something? 
>>> $ irb 
>>>>> require 'radiant' 
>>> => true 
>>>>> quit 
>> Doesn't that assume radiant-as-a-gem or something?
> hm. you are not running of the radiant gem? did you do a app install? why? 
> 'cause you are on edge?

No, 'cos I'm running variously 0.6.9 and 0.8.1
and did an app install to get around other problems that existed then.

Will I update?
Not before I've replicated on my development machine and have confidence
in 0.9x and someone sorts out the problems that seem to exist in

What problems?  Well when I rolled back from 4.3.2 to 4.1.1 everything
ran fine....   Hello Mr Garber?  Do you want to talk about this or not?

>> I ask because when I run that on sites I have that *do* work I get
>> [laney:/home/antonaylward/SystemI]$ irb
>> irb(main):001:0> require 'radiant'
>> LoadError: no such file to load -- radiant
>>        from (irb):2:in `require'
>>        from (irb):2
>> Lets not forget, however, that this is going to behave very differently
>> depending on the context in which I run it.  
> sure. I wanted you to check if your user account is set up right 

Since it runs a site fine, I think it must be :-)

> (so when you install the radiant gem you really get it)
> this differs for the user radiant (or better apache with passenger ...) 
> and a lot of other stuff, I know

Such as I run at Dreamhost....

>> Why? Because the code that
>> makes up radiant redefines Kernel#require.   Go check.  That's what
>> 'custom_require' is all about.  That was what the now obsolete but
>> rather more obvious 'require_gem' was about.
> yes. and with old gem installs you needed to load rubygems before that. I 
> know this.

It helps if you say that at the start :-)

I keeps saying, in fact I'm so famous for it that people say "As Anton
keeps saying ..."

        Context is Everything

  out of memory
  we wish to hold the whole sky
  but we never will

Reply via email to