Hello!
I've been banging my head against the wall on this one for a bit. I'm
intermediate with my rails skills but this is my first radiant site. I
am trying to deploy to a Radiant 1.0 rc2 to a server hosted at
slicehost. I am hoping a kindly, intelligent soul will take pity on me
and shed some light on my problems....which are small in number, but
mysterious in nature:

So - everything works - except for the member extension. That gives me
a blank passenger error, a la:

Application error
Rails application failed to start properly


If I take a peek at the apache error log, it's disappointingly sparse
in detail:
[Mon Sep 12 19:23:22 2011] [error] [client 184.64.72.242] malformed
header from script. Bad header=email=; path=/admin/members: admin
[ pid=16859 thr=140540931016512 file=ext/apache2/Hooks.cpp:851
time=2011-09-12 19:23:22.200 ]: The backend application (process
15900) didn't send a valid HTTP response. It might have crashed during
the middle of sending an HTTP response, so please check whether there
are crashing problems in your application. This is the data that it
sent: [email=; path=/admin/members]

Doesn't help much eh?

Here are some details:
Ubuntu 10.04 LTS
ruby 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux]
Gems:

activemodel (3.1.0)
activerecord (3.1.0)
activesupport (3.1.0)
acts_as_list (0.1.4)
arel (2.2.1)
bcrypt-ruby (3.0.0)
builder (3.0.0)
cocaine (0.2.0)
compass (0.10.6)
daemon_controller (0.2.6)
delocalize (0.2.6)
fastercsv (1.5.4)
fastthread (1.0.7)
haml (3.0.25)
i18n (0.6.0)
mime-types (1.16)
multi_json (1.0.3)
mysql (2.8.1)
paperclip (2.3.3)
passenger (3.0.9)
rack (1.1.2)
radiant (1.0.0.rc2)
rake (0.8.7)
RedCloth (4.2.8)
rubygems-update (1.8.10)
tzinfo (0.3.29)
uuidtools (2.1.2)
will_paginate (2.3.16)

The extensions I have installed are member, settings and tiny_paper.
Member requires the autocomplete plugin which is the only plugin I
have installed.

OH and also: if I run script/server -e production, the extension works
just fine (as it does in my development environment) so webrick has no
issues with this, seems like it is a passenger-apache thing.

Any idears fellers?

Thanking you kindly in advance, even if all you did was read this,
shrug and move on :)

Reply via email to