I have removed the !omap statements; syck does not seem to handle them 
well..
At some point the order of db fixtures needed to be fixed to prevent 
errors, but this seems to be no longer the case.
At least, the Roasters template never used !omap, and has always worked 
fine for me..

I just released 1.0.6 of radiant-site_templates-extension, could you update 
your Gemfile and affirm that all the templates can be chosen again?

Cheers,
Benny

Op dinsdag 2 oktober 2012 18:24:03 UTC+2 schreef Jim Gay het volgende:
>
> Thanks for looking into this. 
>
> We must have some YAML formatting problem in the site_templates 
> extension (https://github.com/radiant/radiant-site_templates-extension) 
> I ran into this before when I was testing things out for 1.9.3 (I 
> think) but I don't understand why this would appear again after fixing 
> it. 
>
> I'll try to take a look, but if you have the opportunity, check out 
> the YAML in that project. 
>
> -Jim 
>
> On Mon, Oct 1, 2012 at 10:23 PM, John Moroney 
> <jpmo...@gmail.com<javascript:>> 
> wrote: 
> > I've just replicated this. It appears during the rake db:boostrap, when 
> > selecting a database template. I get the error below when selecting 
> options 
> > 4 and 5. 3 works, but I haven't tried either 1 or 2. 
> > 
> > Select a database template: 
> > 1. Empty 
> > 2. High Five! 
> > 3. Roasters (a coffee-themed blog / brochure) 
> > 4. Simple Blog 
> > 5. Styled Blog 
> > [1-5]: 5 
> > 
> > rake aborted! 
> > undefined method `keys' for #<Syck::Omap:0x007fe391e48a28> 
> > 
> > 
> > Ruby 1.9.3 
> > Gem 1.8.24 
> > Radiant 1.1.0 
> > Rails 2.3.14 
> > 
> > John Moroney 
> > 
> > 
> > 
> > On Friday, 7 September 2012 14:31:05 UTC-7, IamNaN wrote: 
> >> 
> >> Tried three times to get Radiant installed on Linode with Ruby 
> 1.9.3-p194 
> >> and postgres. 
> >> 
> >> Using the installation and setup directions in INSTALL.md, I get the 
> title 
> >> error trying to populate the database with `bundle exec rake production 
> >> db:bootstrap`. 
> >> 
> >> Can you help with that? 
> >> 
> >> On another note... the system requirements aren't listed anywhere that 
> I 
> >> can find. Rails 3 gets blown away by running `gem install radiant` (I 
> think 
> >> because Gemfile.lock is included in the gem). And I'm getting numerous 
> >> deprecation warnings throughout the installation process. Radiant 
> >> development is still active, right? 
>
>
>
> -- 
> Write intention revealing code #=> http://www.clean-ruby.com 
>
> Jim Gay 
> Saturn Flyer LLC 
> 571-403-0338 
>

Reply via email to