On 20.3.2017 12.00, Fernando Reis wrote:

Via Linux system I can see all the records correctly.


Hello Fernando,

This might be caused by Net::DNS version. See below for more.

Regarding your configuration: I tried the config you sent, and here DNS resolution continues fine where it stops for you. In other words, I don't get 'No reply from DNS for SRV request ...'.

The reply I see has SRV records with radius01.fccn.pt and radius02.fccn.pt as data. After receiving the answer, the A and AAAA records are resolved and received correctly. I used a local DNS server with if.fccn.pt realm in Radius request.

If I run:
perl -e 'use Net::DNS;

...

The results are OK.

The script works also. It prints out one NAPTR and two SRVs.

Note that when you run with the Debug configuration option, the extra debug information goes to STDOUT since it comes from Net::DNS, not Radiator. For this reason you can't see it in Radiator logs but have to see what gets printed out in stdout.

After the above, I tried with Net::DNS 1.08 and Radiator failed to get a response for its SRV query. After testing a couple of more versions, a quick test shows that 1.02 is the last version that works.

1.03 causes a crash and 1.04 and later fail similarly. Net::DNS changelog shows that there have been quite a few changes in the recent versions that explain the crash and quite likely are the cause of missed response.

Can you downgrade your Net::DNS module and let us know if it works. We'll need to check why it does not work with the recent versions and see how to fix it.

Thanks for reporting this.
Heikki

--
Heikki Vatiainen <h...@open.com.au>

Radiator: the most portable, flexible and configurable RADIUS server
anywhere. SQL, proxy, DBM, files, LDAP, NIS+, password, NT, Emerald,
Platypus, Freeside, TACACS+, PAM, external, Active Directory, EAP, TLS,
TTLS, PEAP, TNC, WiMAX, RSA, Vasco, Yubikey, MOTP, HOTP, TOTP,
DIAMETER etc. Full source on Unix, Windows, MacOSX, Solaris, VMS, NetWare etc.
_______________________________________________
radiator mailing list
radiator@lists.open.com.au
http://lists.open.com.au/mailman/listinfo/radiator

Reply via email to