On Friday, July 16, 1999 9:36 AM, Arnie Roberts [SMTP:[EMAIL PROTECTED]] wrote:
> Couldn't find output table 'Users199907'. (SQL-S0002)(DBD: st_execute/SQLExecute 

I've solved this. The answer was the obvious one - the tables were indeed not there. 
How they
got deleted I don't know but on re-creating the table this morning I have made much 
Apologies for my stupidity.

I am now unable to log the Timestamp for the accounting request.
If I have

                AccountingTable Users%Y%m
                AcctColumnDef   UserName,User-Name
#               AcctColumnDef   TimeStamp,Timestamp
                AcctColumnDef   CLI,Calling-Station-Id
                AcctColumnDef   ServiceType,Service-Type
                AcctColumnDef   SessionTime,Acct-Session-Time,integer
                AcctColumnDef   InputOctets,Acct-Input-Octets,integer
                AcctColumnDef   OutputOctets,Acct-Output-Octets,integer
                AcctColumnDef   TerminateCause,Acct-Terminate-Cause
                AcctColumnDef   NasIPAddress,NAS-IP-Address

then no problem - everything works fine. If I delete the # for Timestamp then I get

DBD::ODBC::db do failed: [Microsoft][ODBC Microsoft Access 97 Driver] Syntax err
or in INSERT INTO statement. (SQL-37000)(DBD: st_prepare/SQLPrepare err=-1) at R
adius/SqlDb.pm line 189.
Fri Jul 16 11:29:06 1999: ERR: do failed for 'insert into Users199907
                (UserName, NasIPAddress, InputOctets, OutputOctets, SessionTime,
 ServiceType, TimeStamp)
                ('testuser', '', 283, 165, 225, 'Framed-User', '93
2120944')': [Microsoft][ODBC Microsoft Access 97 Driver] Syntax error in INSERT
INTO statement. (SQL-37000)(DBD: st_prepare/SQLPrepare err=-1)
Fri Jul 16 11:29:07 1999: DEBUG: Handling with Radius::AuthFILE

The detail file shows

Fri Jul 16 11:29:07 1999
        User-Name = "testuser"
        NAS-IP-Address =
        Service-Type = Framed-User
        Acct-Status-Type = Stop
        Acct-Input-Octets = 283
        Acct-Output-Octets = 165
        Acct-Session-Id = "00000001"
        Acct-Session-Time = 225
        Timestamp = 932120944

I've tried changing the TimeStamp table column Data Type between number and text 
formats but
the problem is the same.

Any ideas anyone please?



Archive at http://www.thesite.com.au/~radiator/
To unsubscribe, email '[EMAIL PROTECTED]' with
'unsubscribe radiator' in the body of the message.

Reply via email to