> Talking to yourself, first sign of madness and all that, but instead > of hastests I propose 'tested', to indicate that the patch has unit > tests, and that those tests have been run. There's no reason > submitters shouldn't add this keyword themselves, if they wish.
Tested sounds like a great addition. I'd like to propose two more: * trivial - for tiny patches which we could apply in 15 minutes or so. Typically this is a typo fix, a fix for handling nil somewhere that we currently don't. Something which is pretty simple to review and apply. * notests - For patches submitted without unittests These should also be marked XPATCH, because barring exceptional circumstances (or trivial fixes) we don't apply patches which don't include tests. We can set up two more reports for these. We'll keep the trivial queue relatively empty, and people who want to help out can add tests to the notests patches. Thoughts? Comments? -- Cheers Koz _______________________________________________ Rails-core mailing list Rails-core@lists.rubyonrails.org http://lists.rubyonrails.org/mailman/listinfo/rails-core