Hi Med,

Thanks for considering my comment. Your point that the registration of 700/udp 
was not intentional is an important nuance that I previously did not know.

I now see that RFC 5730, section 2.1. Transport Mapping Considerations lists a 
bunch of requirements and ends with the following:

   A transport mapping MUST explain how all of these requirements are
   met, given the transport protocol being used to exchange data.

RFC 5734 does this for TCP. draft-ietf-regext-epp-quic now does this for QUIC. 
There is no document that does this for UDP. Consequently, I am fine with your 
proposal.

Thanks again,
Charles

On Jul 2, 2026, at 11:20 PM, [email protected] wrote:

Hi Charles,

Thank you for raising this point.

FWIW, there were also offline discussions with the service port designated 
experts as they were concerned that the port can't be safely reused if the spec 
does not clarify how to demux with DTLS. My take on this is to make it clear 
(including the description as you suggested) that this port number is used ** 
exclusively ** by EoQ.

As a reminder, 700/udp was reserved at the time while there was not actual 
need/explicit request. The practice was that companion port numbers are 
reserved systematically, but that is now changed with RFC6335.

Cheers,
Med

-----Message d'origine-----
De : Charles Eckel via Datatracker <[email protected]<mailto:[email protected]>>
Envoyé : vendredi 3 juillet 2026 00:52
À : The IESG <[email protected]<mailto:[email protected]>>
Cc : 
[email protected]<mailto:[email protected]>;
 [email protected]<mailto:[email protected]>;
[email protected]<mailto:[email protected]>; 
[email protected]<mailto:[email protected]>; 
[email protected]<mailto:[email protected]>
Objet : [iesg] Charles Eckel's No Objection on draft-ietf-regext-
epp-quic-10: (with COMMENT)


Charles Eckel has entered the following ballot position for
draft-ietf-regext-epp-quic-10: No Objection

When responding, please keep the subject line intact and reply to
all email addresses included in the To and CC lines. (Feel free to
cut this introductory paragraph, however.)


------------------------------------------------------------------
COMMENT:
------------------------------------------------------------------

Seeing all the helpful points already raised by others in their
reviews, the
only additional comment I have is with respect to the reuse of
port 700.

I see the WG discussed and reached consensus to reassign the
reference for UDP
port 700 to the EPP-over-QUIC specification rather than assign a
new port
number, citing the absence of any known legacy UDP
implementations. In order to
safely accommodate any implementation that may exist now or in the
future, it
might be helpful to add a reference to RFC 9443 and mention that
this mechanism
can be used to demultiplex EPP over UDP from EPP over QUIC.



____________________________________________________________________________________________________________
Ce message et ses pieces jointes peuvent contenir des informations 
confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce 
message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages 
electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou 
falsifie. Merci.

This message and its attachments may contain confidential or privileged 
information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete 
this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been 
modified, changed or falsified.
Thank you.

_______________________________________________
regext mailing list -- [email protected]
To unsubscribe send an email to [email protected]

Reply via email to