Thank you for your reply. When I come to upload my data though, I see there
are only 4 available slots I can upload my data. I have a total of 6 data
files however, that need to be uploaded (3 of each frequency). I also need
to upload the relax -i of 2 different computers, and the script file I've
been using for a total of 9 files that need to be uploaded. Is there a way
to increase the amount I can upload, or can I upload more after the initial

On Mon, Sep 5, 2016 at 2:46 AM, Troels Emtekær Linnet <
> wrote:

> Hi Sam.
> To solve this problem, it would be easier to have access to some of your
> data.
> Can you upload to:
> Take each of your data files, and delete all data, except 2 spins.
> Also provide your script file, or a description of which button you press
> in the GUI.
> Please also provide information about your system with:
> relax -i
> Then I will make a tutorial for you. To be added here:
> If there is a problem in relax, I will write a systemtest which will solve
> the problem.
> And the problem will never return.
> If this a user error, the tutorial should help to prevent this, and would
> be the first step before
> adding/modifying the manual.
> Regarding using mpirun.
> Have a look at this page. Maybe it helps.
> Cheers.
> 2016-09-03 4:13 GMT+02:00 Mahdi, Sam <>:
>> Hello everyone,
>> So I was able to set up and run the dauvergne_protocol successfully by
>> using the script in the wiki. The problem I have come across now is the
>> program doesn't seem to read my data. Using the gui interface I was able
>> to
>> successfully load my data and run it. When I upload my data using the
>> script command:
>> file='R1_Agnes',res_num_col=1,data_col=2,error_col=3)
>> The output file simply gives errors for amino acids I don't have data for:
>> RelaxWarning: The sequence data in the line ['1'] is invalid, the data is
>> missing.
>> This is fine as relax just ignores these values and continues its
>> calculations. I only receive this warning for values I don't have data
>> for.
>> This is the same thing I got when using the gui interface (the gui however
>> showed my values that I have data for and the residue it corresponds to,
>> using the script I don't receive such an output, I don't know whether this
>> is normal or not). However, since I don't get this warning for every amino
>> acid, I assume this means it has read the values for the other amino
>> acids.
>> All of my data is the same, relax warnings only pop up for amino acids
>> that
>> I don't have data for. The problem is, when I enter the dAuvergne
>> protocol,
>> I get the protocol working, it starts running local_tm however it appears
>> none of my data has been uploaded:
>> RelaxWarning: The spin '#hRGS7:2@N' has been deselected because of
>> missing
>> relaxation data
>> RelaxWarning: The spin '#hRGS7:3@N' has been deselected because of
>> missing
>> relaxation data
>> And I get that warning for every single amino acid. From the output, it
>> appears to have read the file since it knows exactly which amino acids I
>> don't have data for, but I don't know why when it comes to running the
>> protocol, it tells me I havn't inputed any data. I have typed everything
>> directly according to the script from the wiki. From running the protoco,
>> it appears everything has properly been uploaded, structure data, magnetic
>> dipole interactions, csa, the data pipe, the analysis variables, the
>> python
>> module imports, and setting up the spins from the pdb file. It appears the
>> only error is from loading the actual relaxation data.
>> On a completely unrelated side note, I have been attempting to run relax
>> on
>> multiple processors. I have tried 2 different computers, both fedora
>> linux.
>> I have mpi4py and openmpi downloaded on both. On one, I can get relax on
>> multiple cores working (havn't been able to successfully run it due to
>> being unable to upload any data properly). On the other however, I type in
>> the mpirun -np --multi='mpi4py' script, but I get no output. I can see
>> that
>> it's running in the background (top command), but nothing pops up, no text
>> command, nothing. I typed the same mpirun with the --gui, but that opened
>> up nothing. On a uni-processor (typing in the exact same command without
>> indicating how many cores i.e. no -np --multi='mpi4py') it works just
>> fine,
>> so I don't think its my openmpi that's an issue. I don't know whether this
>> is an issue with my mpi4py or a personal computer issue (since on the
>> other
>> computer relax runs just fine on multiple cores).
>> Sincerely,
>> Sam
>> P.S. when I do enter the top command to see what's running. My master
>> shows
>> mpirun, and the 3 slaves display python when I put -np 4, so I know
>> something is running in the background. I have 8 cores.
>> On Wed, Aug 31, 2016 at 6:49 PM, Mahdi, Sam <>
>> wrote:
>> > Hello everyone,
>> >
>> > I am attempting to run relax on a multi-processor mode. I have been able
>> > to successfully set-up relax to operate in a multi-processor mode by
>> using
>> > the mpirun -np #ofprocessors /location/of/relax --multi='mpi4py'
>> >
>> > The problem I encounter is when using the --tee log
>> > command. I receive this error
>> > RelaxError: the script file '' does not exist
>> >
>> > I located the script file and tried to direct to it's path
>> > mpirun /usr/local/Relax/relax-2.2.5/relax --multi='mpi4py' --tee log
>> > /usr/local/Relax/relax-2.2.5/auto-analyses/
>> >
>> > But i received this error
>> > RelaxError: the script file '/usr/local/Relax/relax-2.2.5/
>> > auto-analyses/' does not exist.
>> >
>> > Even though I have the script, it doesn't seem to be able to locate it.
>> >
>> > On a side note, in the manual, one dash doesn't actually run the
>> command.
>> > I.e. in the manual it displays -multi='mpi4py' . What it should be is
>> > --multi='mpi4py' . The same goes for -tee. It should be --tee.
>> >
>> > Sincerely,
>> > Sam
>> >
>> _______________________________________________
>> relax (
>> This is the relax-users mailing list
>> To unsubscribe from this list, get a password
>> reminder, or change your subscription options,
>> visit the list information page at
relax (

This is the relax-users mailing list

To unsubscribe from this list, get a password
reminder, or change your subscription options,
visit the list information page at

Reply via email to