Your message dated Sun, 30 Aug 2015 00:29:23 +0100
with message-id 
and subject line Re: Bug#796945: reportbug: UI epic-fails
has caused the Debian Bug report #796945,
regarding reportbug: UI epic-fails
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: reportbug
Version: 6.6.3
Severity: normal
Tags: upstream patch

Ok, I see this is using python-vte for the UI. Im not an expert in UI
programming but.....

the following applies:

we should detect if python-vte is being ran.

Reason behind this is that UI elements and only UI elements apply and affect a
UI application. You cannot close a UI application but hitting enter unless
someone default selected a close button. Nobody has done so. This results in an
empty input dialog and nothing happening. The text input dialog is not needed
in the UI.

IIRC, you can still issue a pause command in linux..but if not its only a few
lines of code to add in:

writeln("Press any key to continue..")

Ok, well this is python but you get by drift.

And of course I want to close reportbug if I click on close button. Why does it
ask me?

Similar UI glitches abound in the UI of reportbug in various areas.

-- Package-specific info:
** Environment settings:

** /home/me/.reportbugrc:
reportbug_version "6.6.4"
mode advanced
ui gtk2
realname "Richard Jasmin"
email ""
smtphost ""
smtpuser ""
smtppasswd <omitted>

-- System Information:
Debian Release: 8.1
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.16.0-4-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages reportbug depends on:
ii  apt     
ii  python            2.7.9-1
ii  python-reportbug  6.6.3
pn  python:any        <none>

reportbug recommends no packages.

Versions of packages reportbug suggests:
pn  claws-mail                                 <none>
pn  debconf-utils                              <none>
pn  debsums                                    <none>
pn  dlocate                                    <none>
pn  emacs23-bin-common | emacs24-bin-common    <none>
ii  exim4                                      4.84-8
ii  exim4-daemon-light [mail-transport-agent]  4.84-8
ii  file                                       1:5.22+15-2
ii  gnupg                                      1.4.18-7
ii  python-gtk2                                2.24.0-4
ii  python-gtkspell                            2.25.3-13
pn  python-urwid                               <none>
ii  python-vte                                 1:0.28.2-5
ii  xdg-utils                                  1.1.0~rc1+git20111210-7.4

Versions of packages python-reportbug depends on:
ii  apt     
ii  python-debian     0.1.27
ii  python-debianbts  1.12
pn  python:any        <none>

python-reportbug suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
closing, it was not worth my time replying in the first place.

Sandro Tosi (aka morph, morpheus, matrixhasu)
My website:
Me at Debian:

--- End Message ---
Reportbug-maint mailing list

Reply via email to