Just read over the repoze.curry docs--looks really cool!
I was glad to see at the end that you had a "static" decorator on the to-do
list. I had thought of that while reading your docs and was going to
suggest it anyway. I was wondering, though, if "const" might be a better
name for it. Marking a function as "const" would be morally equivalent to a
C++ function with all of its arguments declared const. (key difference, of
course, that C++ compiler actually enforces this.) static generally implies
something different in most languages that use it.
That's just a nit, though. I enjoyed the morning brain stim.
Repoze-dev mailing list