2009/6/3 Chris Rossi <ch...@archimedeanco.com>:
> Just read over the repoze.curry docs--looks really cool!

Thanks :-)

> I was glad to see at the end that you had a "static" decorator on the to-do
> list.  I had thought of that while reading your docs and was going to
> suggest it anyway.  I was wondering, though, if "const" might be a better
> name for it.  Marking a function as "const" would be morally equivalent to a
> C++ function with all of its arguments declared const.  (key difference, of
> course, that C++ compiler actually enforces this.)  static generally implies
> something different in most languages that use it.

You may be right; ``const`` could be a better term. I'm not too much
into the lingo of computer languages at large.

Repoze-dev mailing list

Reply via email to