Hi Damien,

Done.

I also updated the index as follows:

zope.interface 3.5.1 -> 3.5.3
zope.i18n 3.7.0 -> 3.7.3
zope.component 3.6.0 -> 3.9.1

and I removed zope.proxy (not necessary)..

- C


Damien Baty wrote:
>       Hello,
> 
>   When installing repoze.bfg, I currently get "zope.component" 3.6.0,
> since this is the version available in the known good set at
> http://dist.repoze.org/bfg/1.2/simple/
> 
> Do you think it could be updated to a more recent version? I am mostly
> interested in "zope.component" 3.8.0 where dependencies on "zope.proxy"
> and "zope.security" have been removed from "zope.component.zcml" (more
> precisely, there is no hard dependency anymore). [1]
> 
> The change log (http://pypi.python.org/pypi/zope.component#changes)
> looks harmless but I may be missing something.
> 
> I have run the BFG trunk tests with the latest version of
> "zope.component" (3.9.1) without any error. I also have run the tests of
> a small application that makes a very simple use of the ZCA (indirectly,
> cf. [1]) but it is not really significant.
> 
> (I know I could pin down the version of zope.component in my own
> application, of course.)
> 
> 
> [1] Use case: I would like to use the "i18n:registerTranslations" ZCML
> directive. But "zope.i18n.zcml" imports "zope.component.zcml". I could
> of course add a dependency on these required "zope.security" and
> "zope.proxy" in my application but this does not look like the right
> thing to me. (The alternative is of course to mimic what this ZCML
> directive does, which I did, first. But I would like to avoid that if
> possible.)
> 

_______________________________________________
Repoze-dev mailing list
Repoze-dev@lists.repoze.org
http://lists.repoze.org/listinfo/repoze-dev

Reply via email to