On Fri 2016-09-09 01:33:00 +0200, HW42 wrote:
> According to codesearch.d.n it seems only SOURCE_DIR_ROOT isn't taken
> yet. (Google finds at least one case).

thanks for looking, that's what i should have done in the first place.

> also bikeshedding: I dislike SOURCE_DIR_ROOT because the name is some
> how redundant. What's the difference between SOURCE_DIR and
> SOURCE_DIR_ROOT? But I don't care much about the naming.

if i've got some source with code in three directories, they're all
SOURCE_DIRs, but only the top level is SOURCE_DIR_ROOT.

> Btw: Do you know why currently debug-prefix-map maps the source dir to
> '.'? (My guess is because that's the easiest in dpkg-buildflags) I think
> for debugging between package boundaries '${srcpkg}-${srcver}' would be
> much better.

I guess i don't have much of an opinion either way here, as long as it
only adds noise to the -dbgsym packages.


Reproducible-builds mailing list

Reply via email to