On Sat, Sep 10, 2016 at 05:08:13PM +0100, Chris Lamb wrote:
> My gut tells me it's using the older, "system-wide" strip-nondeterminism
> libraries for the tests instead of version in the build directory, ie.
> the tests would pass under 0.026 but as it's using 0.025 they fail.

Then I'd have expected it to fail also in the buildds...

> (I can't think why it would do this given that it does not do this locally
> AFAICT. I am also not sure if the debci tests take this into account.)

debci tests only the system-installed libraries, but it takes care that
the installed ones are on the interested version, e.g. it tested
installed 0.026.

                        Mattia Rizzolo

GPG Key: 66AE 2B4A FCCF 3F52 DA18  4D18 4B04 3FCD B944 4540      .''`.
more about me:  https://mapreri.org                             : :'  :
Launchpad user: https://launchpad.net/~mapreri                  `. `'`
Debian QA page: https://qa.debian.org/developer.php?login=mattia  `-

Attachment: signature.asc
Description: PGP signature

Reproducible-builds mailing list

Reply via email to