I think I fixed the problem.  I had to add additional libraries to the make
command.  I changed this:

make "PROXY_LIBS=-lpthread -lc"; 

to this:

make "PROXY_LIBS=-lpthread -lc -lcrypto -lssl";

Resin now starts with OpenSSL configured.

"OpenSSL support compiled for OpenSSL 0.9.8c 05 Sep 2006"


Ed.Hager wrote:
> I am running Ubuntu 7.04, JDK 1.6 and Resin Professional 3.1.s070827.
> I am trying to use OpenSSL.   I followed the instructions here:
> http://bugs.caucho.com/view.php?id=1924
> That helped get past JNI issues.  But now I get this:
> symbol lookup error: /usr/local/resin3.1/libexec/libresinssl.so: undefined
> symbol: OPENSSL_add_all_algorithms_noconf
> I have OpenSSL 0.9.8c installed.  Is my problem that Resin is not
> compatible with this version of OpenSSL?  Or, do I have some other
> configuration problem?
> Ed

View this message in context: 
Sent from the Resin mailing list archive at Nabble.com.

resin-interest mailing list

Reply via email to