On 9/26/14, 2:28 AM, BUSCH Steffen wrote:


Hi Scott,

finally I'm preparing to move from Resin 3.1 to 4.0 and wondering if it would be possible if you could add legacy-support for the *old-encoding* feature to the XmlAuthenticator. I've been using it in many quite old 3.1 files like this:

  <authenticator type="com.caucho.server.security.XmlAuthenticator">

    <init>

      <password-digest old-encoding="true" algorithm="MD5" />

<password-digest-realm>none</password-digest-realm>

      <path>passwords.xml</path>

    </init>

  </authenticator>

Any chance?


Would a conversion program work for you? The old-encoding was an old bug where base64 wasn't implemented properly. I'd prefer to keep that code out of the main authentication code.

-- Scott

Thanks,

Steffen



_______________________________________________
resin-interest mailing list
resin-interest@caucho.com
http://maillist.caucho.com/mailman/listinfo/resin-interest

_______________________________________________
resin-interest mailing list
resin-interest@caucho.com
http://maillist.caucho.com/mailman/listinfo/resin-interest

Reply via email to