As it turned out, I didn't have the javax.ws.rs.Consumes and
javax.ws.rs.Produces annotations on my subclass of ResteasyJacksonProvider.
 Once I added those, it works fine.  I'm still not sure why it worked on
one machine and not another, but at least now it works consistantly.
 Hopefully this'll help someone else avoid this pitfall.


On Thu, May 16, 2013 at 10:46 AM, Philip Chapman <pchap...@pcsw.us> wrote:

> Guys,
> I have a strange issue that I can't get a handle on.  A case of "It works
> on my machine" that's driving me crazy.  I have  implemented a subclass
> of org.jboss.resteasy.plugins.providers.jackson.ResteasyJacksonProvider,
> annotated the class with javax.ws.rs.ext.Provider and ensured that the
> fully qualified class name exists in
> META-INF.services/javax.ws.rs.ext.providers.
> If I deploy it as a war in jetty 8.1.10 on my machine, the custom
> providers are used  to serialize  a joda DateTime object.  On my server
> running the same version of jetty or  tomcat 7.0.40, the providers are not
> used and toString() on the object is used instead.   I am using OpenJDK
> 1.7.0_21(64 bit) on both machines, but have also tried Oracle java 1.7.0_21
>  on the server.
> I am at a loss as to how to debug why it isn't running properly in
> production.
> --
> Philip A. Chapman
> Java Software Development
> Enterprise, Web, and Desktop

Philip A. Chapman
Java Software Development
Enterprise, Web, and Desktop
AlienVault Unified Security Management (USM) platform delivers complete
security visibility with the essential security capabilities. Easily and
efficiently configure, manage, and operate all of your security controls
from a single console and one unified framework. Download a free trial.
Resteasy-users mailing list

Reply via email to