Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 1334 by Fragment expansion brings up 404 error

*NOTE: Do not post confidential information in this bug report.*

What version are you running?

What's the URL of the page containing the problem?

What steps will reproduce the problem?
1. Submit a review request through Post Review
2. In draft mode, click on "View Diff" once
3. Publish the review request
4. Open the request (either as submitter or reviewer)
5. Click on "View Diff"
6. Try to expand expand a hidden source code section by clicking on "Expand"

What is the expected output? What do you see instead?
Clicking on any of the "Expand" hyperlinks (to expand collapsed source code
sections) in the RB diff viewer brings up a 404 error. The URL to retrieve
the file fragment uses an incorrect diff index (0 instead of 1), such as:

Manually invoking the URL with a corrected diff # correctly retrieves the

What operating system are you using? What browser?
Server: Windows Server 2003. Client: browser-independent.

Please provide any additional information below.

The issue only occurs when selecting "View Diff" at least once in draft
mode and does not occur when blindly publishing the review request.

You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to