Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 1572 by operatest: git repository matching is too strict (should ignore username)

*NOTE: Do not post confidential information in this bug report.*

What version are you running?

1.5 beta 1

What steps will reproduce the problem?
1. You have a git repository with path
configured in Review Board
2. Your git username is BAR, your local computer username is FIE
3. You clone the repository with
4. Trying to upload reviews with post-review will fail because
"" will not match "

What is the expected output? What do you see instead?

I would expect post-review to succeed because "
git" and "" are identical after filtering away
the username. Instead I get:

"The repository path specified is not in the list of known repositories"

I also tried to add multiple remote urls (which is possible in git) but
that gave "error: More than one value for the key remote.origin.url"

What operating system are you using? What browser?

Linux both as server and client. Browser Opera though in this case all the
commands were done through the command line.

You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to