Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 2226 by prabhat....@gmail.com: Exception thrown for user at http://gitdepot:8088/api/json/reviewrequests/2339/publish/
http://code.google.com/p/reviewboard/issues/detail?id=2226

* NOTE: Do not post confidential information in this bug report. *
*       If you need immediate support, please contact            *
*       reviewbo...@googlegroups.com                             *

What version are you running?
1.5.4

What's the URL of the page containing the problem?
Not Accessible publically

What steps will reproduce the problem?
1.Create a new review.
2.Fill in the fields.  Diff is ok.
3.Receive json/django error on publish:
"TypeError: character mapping must return integer, None or unicode"

What is the expected output? What do you see instead?
Expected: publish review
Observed: Server 500 error

What operating system are you using? What browser?
RHEL-5.4
Firefox

Please provide any additional information below.

'ascii' codec can't encode character u'\u2014' in position 175: ordinal not in range(128)
Traceback (most recent call last):
File "/usr/lib/python2.4/site-packages/Django-1.2.5-py2.4.egg/django/core/handlers/base.py", line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
File "/usr/lib/python2.4/site-packages/Django-1.2.5-py2.4.egg/django/views/decorators/cache.py", line 78, in _wrapped_view_func
    response = view_func(request, *args, **kwargs)
File "/usr/lib/python2.4/site-packages/ReviewBoard-1.5.4-py2.4.egg/reviewboard/webapi/decorators.py", line 61, in _view
    response = view_func(*args, **kwargs)
File "/usr/lib/python2.4/site-packages/Djblets-0.6.7-py2.4.egg/djblets/webapi/decorators.py", line 88, in _checklogin
    return view_func(*args, **kwargs)
File "/usr/lib/python2.4/site-packages/ReviewBoard-1.5.4-py2.4.egg/reviewboard/webapi/json.py", line 454, in review_request_publish
    review_request.publish(request.user)
File "/usr/lib/python2.4/site-packages/ReviewBoard-1.5.4-py2.4.egg/reviewboard/reviews/models.py", line 519, in publish
    changes = draft.publish(self, send_notification=False)
File "/usr/lib/python2.4/site-packages/ReviewBoard-1.5.4-py2.4.egg/reviewboard/reviews/models.py", line 838, in publish
    os.system(xbug_upd_cmd)
UnicodeEncodeError: 'ascii' codec can't encode character u'\u2014' in position 175: ordinal not in range(128)




Attachments:
        gitdepot.htm  10.2 KB

--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to reviewboard-issues@googlegroups.com.
To unsubscribe from this group, send email to 
reviewboard-issues+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/reviewboard-issues?hl=en.

Reply via email to