Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 2320 by m.sahala...@gmail.com: User password is not passed to ssh client
http://code.google.com/p/reviewboard/issues/detail?id=2320

* NOTE: Do not post confidential information in this bug report. *
*       If you need immediate support, please contact            *
*       reviewbo...@googlegroups.com                             *

What version are you running?

rb RC2

What's the URL of the page containing the problem?
-

What steps will reproduce the problem?

Same as in http://groups.google.com/group/reviewboard/browse_thread/thread/9f14cc242a9ef367/9e1ca7b2f2683fda?lnk=gst&q=Authentication+%28password%29+successful#9e1ca7b2f2683fda

In short, trying to add svn+ssh://svnpath/repo fails when using username/pwd

2011-10-05 20:03:50,636 - INFO - Authentication (password) successful!
2011-10-05 20:03:50,739 - DEBUG - EOF in transport thread
2011-10-05 20:03:51,337 - ERROR - SVN: Failed to get repository information for svn+ssh://devsvn/eco: To better debug SSH connection problems, remove the -q option from 'ssh' in the [tunnels] section of your Subversion configuration file.


What is the expected output? What do you see instead?



What operating system are you using? What browser?

RHEL 4, Firefox

Please provide any additional information below.

in rbssh.py, line 273 password is set to 0 and then client.connect call is made. Changing the password to a correct one for a given username allows the repository to get registered.

Could you please look into it


--
You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to reviewboard-issues@googlegroups.com.
To unsubscribe from this group, send email to 
reviewboard-issues+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/reviewboard-issues?hl=en.

Reply via email to