Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 3067 by RB can't resolve diff when parent diff is given

*** For customer support, please post to
*** If you have a patch, please submit it to
*** Do not post confidential information in this bug report!

What version are you running?
RB 1.7.13

What's the URL of the page containing the problem?

What steps will reproduce the problem?
1. create new local repo with three changeset, see attachment
2. create new empty central repository, linked to RB
3. push up revision 0 to central repository (don't push up r1 and r2)
4. my intention is to use RB to review changes between rev 1 and rev 2:
5. create parent diff: hg diff -r0 -r1>parent.diff
6. create diff to review: hg diff -r1 -r2>target diff
7. create new review in RB, upload parent.diff & target.diff
8. When clicking "Create Review Request" RB responds with error:
The file 'f1' (r5f714bed7dcc) could not be found in the repository

What is the expected output? What do you see instead?
- I expect RB to create a new review, instead it returns a fault. RB starts looking for file 'f1' (r5f714bed7dcc) in the central repository, but it doesn't exist. This is logical because the listed revision is not in th central repository.

What operating system are you using? What browser?
- tried it from Windows XP and Debian Linux, both give the same result
- browser is Iceweasel

Please provide any additional information below.
- I created the parent and target diff manually to exclude any tool involvement

Attachments:  6.5 KB

You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To post to this group, send email to
Visit this group at
For more options, visit

Reply via email to