Status: New
Labels: Type-Defect Priority-Medium Component-RBTools

New issue 3089 by Cannot post review request using parent diff with git-svn

This was reported via our support channel by Eddie Monge.

"Our company uses a svn repo and I interact with it using git svn (easier branching). I will often make a branch, commit some code, post that code for review, and while I am waiting for the code to be reviewed, create some new commits (either in the same branch or a new branch based off that one). Is there a way to post those new commits without it showing the original commit that is already waiting for a review? It seems like it posts all the commits up until the last dcommit. I tried using the --parent=HEAD~1 but it doesn't seem to work with git svn"

He tried with both 0.5 and 0.5.2 and neither works. The Review Board version is 1.5.4

post-review -do --summary="$SUMMARY" --description="$DESCRIPTION" --bugs="$BUG" --branch="$BRANCH" --testing-done="$TESTING" --parent=HEAD~1 -p

RBTools 0.5
Python 2.7.2 (default, Oct 11 2012, 20:14:37)
[GCC 4.2.1 Compatible Apple Clang 4.0 (tags/Apple/clang-418.0.60)]
Running on Darwin-12.4.0-x86_64-i386-64bit
Home = /Users/eddie
Current Directory = /Users/eddie/Sites/frontend
Checking the repository type. Errors shown below are mostly harmless.
DEBUG:root:Checking for a Bazaar repository...
DEBUG:root:Checking for a CVS repository...
DEBUG:root:Checking for a ClearCase repository...
DEBUG:root:Checking for a Git repository...
DEBUG:root:Running: git rev-parse --git-dir
DEBUG:root:Running: git config core.bare
DEBUG:root:Running: git rev-parse --show-toplevel
DEBUG:root:Running: git symbolic-ref -q HEAD
DEBUG:root:Running: git svn info
DEBUG:root:repository info: Path: svn://zob, Base path: /repo/trunk/apps/frontend, Supports changesets: False
Finished checking the repository type.
HTTP GETting api/info/
DEBUG:root:Running: git merge-base HEAD~1 refs/heads/2-p-sidebar
DEBUG:root:Running: git diff --no-color --no-prefix --no-ext-diff -r -u HEAD~1
DEBUG:root:Running: git svn find-rev HEAD~1
DEBUG:root:Running: git diff --no-color --no-prefix --no-ext-diff -r -u c2794c6490b6a87e96ca7f0d3806561d481ab029..HEAD~1 DEBUG:root:Running: git svn find-rev c2794c6490b6a87e96ca7f0d3806561d481ab029
Traceback (most recent call last):
  File "/usr/local/bin/post-review", line 8, in <module>
    load_entry_point('RBTools==0.5', 'console_scripts', 'post-review')()
File "build/bdist.macosx-10.8-intel/egg/rbtools/", line 1310, in main
TypeError: object of type 'NoneType' has no len()

You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To post to this group, send email to
Visit this group at
For more options, visit

Reply via email to