Labels: Type-Defect Priority-Medium
New issue 3598 by step...@gallagherhome.com: Make the markdown requirement
What version are you running?
Review Board 2.0.8
What's the URL of the page containing the problem?
What steps will reproduce the problem?
1. Attempt to install Review Board 2.0.8 on the OpenShift PaaS platform
What is the expected output? What do you see instead?
ReviewBoard should be installed. Instead, an error is encountered:
remote: error: Installed distribution Markdown 2.4 conflicts with
What operating system are you using? What browser?
Please provide any additional information below.
I discussed this with Christian on IRC. The issue is that 2.0.8 introduced
a hard dependency on Markdown 2.4.1 in order to ensure that 2.5 or later
was not pulled in by easy_install on python 2.6 systems. Unfortunately,
this does not play well with PaaS systems or other systems with a fixed
Markdown version on them that is not *exactly* 2.4.1.
As discussed on IRC, it would be better if this requirement was different
for different versions of python on the system. For systems with python
2.6, it should be set to >= 2.4, < 2.4.9999 and for python 2.7, just >= 2.4.
You received this message because this project is configured to send all
issue notifications to this address.
You may adjust your notification preferences at:
You received this message because you are subscribed to the Google Groups
To unsubscribe from this group and stop receiving emails from it, send an email
To post to this group, send email to email@example.com.
Visit this group at http://groups.google.com/group/reviewboard-issues.
For more options, visit https://groups.google.com/d/optout.