I get this error on the server when using post-review to submit a diff
for reviewing.

My setup is : WinXP + python 2.5 + apache 2.0 - mod_python + pysvn.

Here's what I get as the output from post-review:

ImportError at /api/json/reviewrequests/16/diff/new/

DLL load failed with error code 182

Request Method:         POST
Request URL:    http://reviewboard/api/json/reviewrequests/16/diff/new/
Exception Type:         ImportError
Exception Value:

DLL load failed with error code 182

Exception Location:     c:\python25\lib\site-packages\pysvn\__init__.py
in <module>, line 93
Python Executable:      C:\Program Files\Apache Group\Apache2\bin
Python Version:         2.5.2
Python Path:    ['C:\\Python25\\lib\\site-packages\\setuptools-0.6c3-
py2.5.egg', 'C:\\Python25\\lib\\site-packages\\pygments-0.11.1-
py2.5.egg', 'c:\\Python25', 'C:\\WINDOWS\\system32\\python25.zip', 'c:\
\python25\\lib\\site-packages\\pil', 'c:\\python25\\lib\\site-
packages', 'C:\\Python25\\Lib', 'C:\\Python25\\DLLs', 'C:\\Python25\
\Lib\\lib-tk', 'C:\\Program Files\\Apache Group\\Apache2\\bin', 'C:/
Temp/Django-1.0', 'D:/', 'd:/reviewboard', 'C:/Python25/Lib/site-

The only tool I could use (seems that the .dll name is not reported,
I've checked the whole output), I had to revert to Dependency Walker
to see what .dll are requested at runtime (by Apache).

Seems that there are two libraries which are looked for, but not
These both are in pysvn as well as libsvn folders somewhere inside c:

Dependency Walker says: LoadLibraryExA("c:\python25\lib\site-packages
\pysvn\_pysvn_2_5.pyd", 0x00000000, LOAD_WITH_ALTERED_SEARCH_PATH)
returned NULL by thread 254. Error: ...
(the error says something about the operating system not able to open
%1) and this is about as much as I could get out of it.

What I tried:
a) copy both dlls to apache's bin directory.
b) set the PATH to include them then start apache after making sure
that the PATH did contain the paths.
c) added the paths to PythonPath variable inside apache's httpd.conf

Still no luck..

As this is my first time I'm using python + all the modules, I feel a
bit lost :) and wondered if you guys have any ideea.
Maybe this is all related to python 2.5 ? I tried with 2.6 but the
only this I could have used (as mod_python is not yet compiled for
2.6) was fastcgi which I tried to first avoid it.

You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 

Reply via email to