Sure, Here are the steps

1. I did not login, i.e. I am an anonymous user.
2. I opened the review request diff. (Still anonymous)
3. I view the diff and enter comments on some lines (Still anonymous)
4. The publish button is still shown here (still anonymous)
5. I click publish thinking that my comments will go, but since I am
anonymous these comments are not posted.
6. Comments are lost and Nothing is published.

Comments not posted is fine, but all my efforts in writing those
comments is lost. So at the time when anonymous user tries to write
the comment there itself he should be stopped and asked to login.

Thanks,
Kunal


On May 4, 2:42 pm, Christian Hammond <chip...@chipx86.com> wrote:
> Sorry, I'm trying to understand this correctly.
>
> The user starts out as logged in, or anonymous?
>
> Are you saying he's able to make comments while anonymous?
>
> If you can give me a detailed, step-by-step repro case, it would help.
>
> Christian
>
> --
> Christian Hammond - chip...@chipx86.com
> Review Board -http://www.review-board.org
> VMware, Inc. -http://www.vmware.com
>
> On Mon, May 4, 2009 at 2:22 AM, KunalG <kunal.gosw...@gmail.com> wrote:
>
> > well, the anonymous user is not able to post comments.
> > But the problem is when he tries to save comments on particular lines
> > he is able to save. And the publish button is also shown to him. But
> > when he publishes, the comments are not published. So at the first
> > step itself the anonymous user should be prompted to login.
> > Is this the case ?
>
> > -Kunal
>
> > On May 4, 2:19 pm, KunalG <kunal.gosw...@gmail.com> wrote:
> > > I installed first release build i.e. 1.0. Is there any place where I
> > > can check the installed build ?
>
> > > -Kunal
>
> > > On May 4, 2:16 pm, Christian Hammond <chip...@chipx86.com> wrote:
>
> > > > Which version are you running? You shouldn't be able to post comments
> > in the
> > > > diff viewer if you're not logged in.
>
> > > > Christian
>
> > > > --
> > > > Christian Hammond - chip...@chipx86.com
> > > > Review Board -http://www.review-board.org
> > > > VMware, Inc. -http://www.vmware.com
>
> > > > On Mon, May 4, 2009 at 1:48 AM, KunalG <kunal.gosw...@gmail.com>
> > wrote:
>
> > > > > Hi
>
> > > > > One problem that we are facing is that when a reviewer posts his
> > > > > comments he is asked to publish the comments.
> > > > > But if the user is not logged in still he gets the same feeling and
> > > > > once he publish the comments, he looses them all because he was not
> > > > > logged in. So he has to login again and write all the comments again.
> > > > > Is there a way this can be prevented ?
>
> > > > > Thanks,
> > > > > Kunal
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to