Hi Tom:
It is a fresh install. I have UnxUtils in PATH,so diff is also
avaiable.

On May 6, 11:44 am, Tom Sakkos <nasis...@gmail.com> wrote:
> Is this a fresh install?
>
> IIRC, I ran into this issue because I didn't have MinGW (sp?) tools
> installed.  ReviewBoard has a dependency on the GNU utils patch and diff.
>
> -Tom
>
> On Tue, May 5, 2009 at 9:39 PM, Noam Bunder <gen...@gmail.com> wrote:
> > Install it on Ubuntu - you will be up and running in minutes.
> > - Just a suggestion.
>
> > On Tue, May 5, 2009 at 10:22 PM, marshall <weixiao...@gmail.com> wrote:
>
> >> Hi ALL:
> >> I just installed reviewboard 1.0 RC1 on an XP sp2 machine with Apache
> >> + MySQL + Subversion configure.the installation is smooth. and  I can
> >> upload svn diff files. but when I push the "ViewDiff" button. I always
> >> got this error message:
> >> [Error 2]
>
> >> Traceback (most recent call last):
> >>  File "c:\python25\lib\site-packages\ReviewBoard-1.0rc1-py2.5.egg
> >> \reviewboard\diffviewer\views.py", line 152, in view_diff
> >>    interdiffset, highlighting, True)
> >>  File "c:\python25\lib\site-packages\ReviewBoard-1.0rc1-py2.5.egg
> >> \reviewboard\diffviewer\diffutils.py", line 620, in get_diff_files
> >>    large_data=True)
> >>  File "c:\python25\lib\site-packages\Djblets-0.5rc1-py2.5.egg\djblets
> >> \util\misc.py", line 143, in cache_memoize
> >>    data = lookup_callable()
> >>  File "c:\python25\lib\site-packages\ReviewBoard-1.0rc1-py2.5.egg
> >> \reviewboard\diffviewer\diffutils.py", line 619, in <lambda>
> >>    enable_syntax_highlighting),
> >>  File "c:\python25\lib\site-packages\ReviewBoard-1.0rc1-py2.5.egg
> >> \reviewboard\diffviewer\diffutils.py", line 342, in get_chunks
> >>    new = get_patched_file(old, filediff)
> >>  File "c:\python25\lib\site-packages\ReviewBoard-1.0rc1-py2.5.egg
> >> \reviewboard\diffviewer\diffutils.py", line 258, in get_patched_file
> >>    return patch(filediff.diff, buffer, filediff.dest_file)
> >>  File "c:\python25\lib\site-packages\ReviewBoard-1.0rc1-py2.5.egg
> >> \reviewboard\diffviewer\diffutils.py", line 107, in patch
> >>    stderr=subprocess.STDOUT)
> >>  File "C:\Python25\Lib\subprocess.py", line 594, in __init__
> >>    errread, errwrite)
> >>  File "C:\Python25\Lib\subprocess.py", line 822, in _execute_child
> >>    startupinfo)
> >> WindowsError: [Error 2]
>
> >> I have searched the group and look at the subprocess.py code. It seems
> >> related to the command line invoke of patch.exe. but I have gnu patch
> >> in my system path. and i can invoke it from windows command window. so
> >> can anyone suggest my further move ? besides the logging seems not
> >> working either. I enable logging in the admin panel. but the logs dir
> >> have no files.
> >> Any feedback is appreciated! thanks for your help. I really really
> >> want to use this pretty software in my group.
>
> >> Regards
>
> >> Marshall
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to