Review Board is fully UTF-8-compliant, but it requires that your database be
made with UTF-8, or that you convert it to UTF-8. Creating a new database
with UTF-8 will be easier, but if you want to convert it, you'll be able to
find instructions through a quick Google search.

If you're using MySQL, then this link might be helpful:
http://codesnippets.joyent.com/posts/show/84

Note that I haven't tried these instructions myself.

I would just recommend starting with a new database if you don't have
anything on that server yet. Again, if MySQL, you can do:

CREATE DATABASE reviewboard CHARACTER SET utf8 COLLATE utf8_general_ci;

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.review-board.org
VMware, Inc. - http://www.vmware.com


On Wed, May 6, 2009 at 8:36 PM, marshall <weixiao...@gmail.com> wrote:

>
> Hi ALL:
> new updates. it seems related to gnus tools dependency. after I add
> unxutil bin to system PATH. the error disappear! really strange. but
> there's another problem emerges. I can't save review contains chinese
> characters. do reviewboard support unicode ? or need some special
> tweaks?
>
> regards
> Marshall
>
> On May 6, 7:25 pm, marshall <weixiao...@gmail.com> wrote:
> > Hi Christian:
> > Thanks for your help. I'll try Ubuntu installation.
> >
> > Regards
> > Marshall
> >
> > On May 6, 1:14 pm, Christian Hammond <chip...@chipx86.com> wrote:
> >
> > > Hi Marshall,
> >
> > > Our logging is not very extensive. We wouldn't have any logging in
> place for
> > > this call at all. The information you have is all that's available
> without
> > > modifying code.
> >
> > > Christian
> >
> > > --
> > > Christian Hammond - chip...@chipx86.com
> > > Review Board -http://www.review-board.org
> > > VMware, Inc. -http://www.vmware.com
> >
> > > On Tue, May 5, 2009 at 10:06 PM, marshall <weixiao...@gmail.com>
> wrote:
> >
> > > > Hi Christian:
> > > > Thanks for quick reply. I think if I can solve the logging problem. I
> > > > can get more info I need. any idea why enable logging doesn't
> > > > working ?
> > > > Since the Windows Error Code 2 is from CreateProcess call. it means
> > > > The system cannot find the file specified. if  i can log the command
> > > > line reviewboard used .maybe I can figure out why.
> >
> > > > Regards
> > > > Marshall
> >
> > > > On May 6, 11:42 am, Christian Hammond <chip...@chipx86.com> wrote:
> > > > > It may be in your PATH, but it could be that your server isn't
> seeing it
> > > > for
> > > > > some reason. Otherwise, I don't really have much advice off-hand,
> not
> > > > having
> > > > > hit this (I do work on Linux primarily), but maybe someone else has
> hit a
> > > > > case of this failing without it being a PATH issue.
> >
> > > > > Christian
> >
> > > > > --
> > > > > Christian Hammond - chip...@chipx86.com
> > > > > Review Board -http://www.review-board.org
> > > > > VMware, Inc. -http://www.vmware.com
> >
> > > > > On Tue, May 5, 2009 at 7:22 PM, marshall <weixiao...@gmail.com>
> wrote:
> >
> > > > > > Hi ALL:
> > > > > > I just installed reviewboard 1.0 RC1 on an XP sp2 machine with
> Apache
> > > > > > + MySQL + Subversion configure.the installation is smooth. and  I
> can
> > > > > > upload svn diff files. but when I push the "ViewDiff" button. I
> always
> > > > > > got this error message:
> > > > > > [Error 2]
> >
> > > > > > Traceback (most recent call last):
> > > > > >  File "c:\python25\lib\site-packages\ReviewBoard-1.0rc1-py2.5.egg
> > > > > > \reviewboard\diffviewer\views.py", line 152, in view_diff
> > > > > >    interdiffset, highlighting, True)
> > > > > >  File "c:\python25\lib\site-packages\ReviewBoard-1.0rc1-py2.5.egg
> > > > > > \reviewboard\diffviewer\diffutils.py", line 620, in
> get_diff_files
> > > > > >    large_data=True)
> > > > > >  File
> "c:\python25\lib\site-packages\Djblets-0.5rc1-py2.5.egg\djblets
> > > > > > \util\misc.py", line 143, in cache_memoize
> > > > > >    data = lookup_callable()
> > > > > >  File "c:\python25\lib\site-packages\ReviewBoard-1.0rc1-py2.5.egg
> > > > > > \reviewboard\diffviewer\diffutils.py", line 619, in <lambda>
> > > > > >    enable_syntax_highlighting),
> > > > > >  File "c:\python25\lib\site-packages\ReviewBoard-1.0rc1-py2.5.egg
> > > > > > \reviewboard\diffviewer\diffutils.py", line 342, in get_chunks
> > > > > >    new = get_patched_file(old, filediff)
> > > > > >  File "c:\python25\lib\site-packages\ReviewBoard-1.0rc1-py2.5.egg
> > > > > > \reviewboard\diffviewer\diffutils.py", line 258, in
> get_patched_file
> > > > > >    return patch(filediff.diff, buffer, filediff.dest_file)
> > > > > >  File "c:\python25\lib\site-packages\ReviewBoard-1.0rc1-py2.5.egg
> > > > > > \reviewboard\diffviewer\diffutils.py", line 107, in patch
> > > > > >    stderr=subprocess.STDOUT)
> > > > > >  File "C:\Python25\Lib\subprocess.py", line 594, in __init__
> > > > > >    errread, errwrite)
> > > > > >  File "C:\Python25\Lib\subprocess.py", line 822, in
> _execute_child
> > > > > >    startupinfo)
> > > > > > WindowsError: [Error 2]
> >
> > > > > > I have searched the group and look at the subprocess.py code. It
> seems
> > > > > > related to the command line invoke of patch.exe. but I have gnu
> patch
> > > > > > in my system path. and i can invoke it from windows command
> window. so
> > > > > > can anyone suggest my further move ? besides the logging seems
> not
> > > > > > working either. I enable logging in the admin panel. but the logs
> dir
> > > > > > have no files.
> > > > > > Any feedback is appreciated! thanks for your help. I really
> really
> > > > > > want to use this pretty software in my group.
> >
> > > > > > Regards
> >
> > > > > > Marshall
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to