I reluctantly used easy_install to get ReviewBoard 1.0 installed on  
my CentOS 5.3 server (I would have preferred to use an RPM based  
install, but that is not available).  I actually started to install  
when 1.0rc2 was the latest but had problems back then as well.  At  
the moment I don't know exactly what versions of all the components  
that are installed, only that easy_install finally completed  
installing all dependencies.  Side question #1: how can I tell  
everything that has been installed by easy_install?  Side question  
#2: how can I uninstall everything installed by easy_install so I can  
start from scratch again?

Anyway, now that everything is installed, I get the following error  
when I try to configure ReviewBoard:

# rb-site install /local/www/html/rb
Traceback (most recent call last):
   File "/usr/lib/python2.4/site-packages/ReviewBoard-1.0-py2.4.egg/ 
reviewboard/cmdline/rbsite.py", line 753, in next_page
   File "/usr/lib/python2.4/site-packages/ReviewBoard-1.0-py2.4.egg/ 
reviewboard/cmdline/rbsite.py", line 918, in call_func
   File "/usr/lib/python2.4/site-packages/ReviewBoard-1.0-py2.4.egg/ 
reviewboard/cmdline/rbsite.py", line 310, in sync_database
     self.run_manage_command("syncdb", ["--noinput"])
   File "/usr/lib/python2.4/site-packages/ReviewBoard-1.0-py2.4.egg/ 
reviewboard/cmdline/rbsite.py", line 347, in run_manage_command
   File "/usr/lib/python2.4/site-packages/ReviewBoard-1.0-py2.4.egg/ 
reviewboard/admin/migration.py", line 13, in fix_django_evolution_issues
     import django.db.models.fields as model_fields
   File "/usr/lib/python2.4/site-packages/Django-1.0.2_final- 
py2.4.egg/django/db/__init__.py", line 16, in ?
     backend = __import__('%s%s.base' % (_import_path,  
settings.DATABASE_ENGINE), {}, {}, [''])
   File "/usr/lib/python2.4/site-packages/Django-1.0.2_final- 
py2.4.egg/django/db/backends/mysql/base.py", line 22, in ?
     raise ImproperlyConfigured("MySQLdb-1.2.1p2 or newer is  
required; you have %s" % Database.__version__)
django.core.exceptions.ImproperlyConfigured: MySQLdb-1.2.1p2 or newer  
is required; you have 1.2.1

I just recently joined this group and have searched through the  
archives for the string "MySQLdb-1.2.1p2 or newer is required" and  
nothing showed up.  However, a Google search did find an email thread  
in this group from last month, but it did not really have a good  
solution: one was to install a new driver and the other to install  
and use a separate Python installation.  I don't know how to do the  
former and don't want to do the latter.

What is the best way to install/configure/run ReviewBoard on a CentOS  
5.3 (or Red Hat Enterprise Linux 5) server?


You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to