Thanks, Christian. I've updated to the newest nightly build.

Now I have found the reason. Thanks to the -d option, I saw the last command
that post-review has executed:
svn diff --diff-cmd=diff http://mysvnserver/@xxx http://mysvnserver/@HEAD

I manually executed it and it asked me for the password, so i know that it
is NOT post-review's fault - our project is restricted to internal use only,
so accessing http://mysvnserver needs password

I managed overcome this but another error occurred:

>>> svn info /directory/of/my/working/copy
>>> repository info: Path: http://mysvnserver, Base path: /, Supports
changesets: False
>>> svn diff --diff-cmd=diff http://mysvnser...@18444 http://mysvnserver
>>> Looking for 'http://myrbserver <http://mysvnserver/>/' cookie in
>>> Loaded valid cookie -- no login required
>>> Attempting to create review request for None
>>> HTTP GETting /api/json/repositories/
>>> HTTP GETting /api/json/repositories/1/info/
>>> repository info: Path: http://mysvnserver, Base path: /, Supports
changesets: False
>>> Submitting the review request as zzz
>>> HTTP POSTing to http://myrbserver 
>>> <http://mysvnserver/>/api/json/reviewrequests/new/:
{'repository_path': u'http://mysvnserver', 'submit_as': 'zzz'}
>>> Review request created
>>> Attempting to set field 'target_groups' to 'ggg' for review request '6'
>>> HTTP POSTing to http://myrbserver 
>>> <http://mysvnserver/>/api/json/reviewrequests/6/draft/set/:
{'target_groups': 'ggg'}
>>> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

<html xmlns="http://www.w3.org/1999/xhtml"; xml:lang="en" lang="en">
  <title>500 - Internal Server Error | Review Board</title>
  <h1>Something broke! (Error 500)</h1>
   It appears something broke when you tried to go to here. This is either
   a bug in Review Board or a server configuration error. Please report
   this to your administrator.

Unable to access http://myrbserver
The host path may be invalid
HTTP Error 500: Internal Server Error

Then I logged in as admin and saw a review request, unpublished. As seen
above, there is something wrong when setting "target_groups" of this
request, it then got interrupted, so diff file is not uploaded.

the target_groups I used contains a hyphen "-", but I don't think it's
invalid because I've successfully created some group in the ReviewBoard
server (I've also created relavent users and set appropriate permissions).

Is there anyway to get more debug information (like post-review -d) rather
than a poor Error 500 page? Thanks!

- Rujia

On Thu, Aug 20, 2009 at 2:46 PM, Christian Hammond <chip...@chipx86.com>wrote:

> Hi Rujia,
> This might be fixed in the nightlies. Can you try a nightly build from
> http://downloads.review-board.org/nightlies/ and see if this fixes the
> problem?
> Christian
> --
> Christian Hammond - chip...@chipx86.com
> Review Board - http://www.review-board.org
> VMware, Inc. - http://www.vmware.com
> On Wed, Aug 19, 2009 at 9:27 PM, rujia <rujia....@gmail.com> wrote:
>> Hi!
>> I'm writing a script to automatically post a review request for every
>> revision, using svn's post-commit hook. When I run this:
>> post-review -d -p --server=http://myrbserver --target-group=xxx --
>> revision-range=xxx --submit-as=someone --username=submitter --
>> password=submitter --repository-url=/directory/of/my/working/copy
>> I got the following message:
>> >>> svn info /directory/of/my/working/copy
>> >>> repository info: Path: http://mysvnserver Base path: /, Supports
>> changesets: False
>> >>> svn diff --diff-cmd=diff http://mysvnserver/@xxx
>> http://mysvnserver/@HEAD
>> Password for 'rujialiu':
>> (I've logged in as user rujialiu. My svn account is also named
>> rujialiu)
>> Even if I entered my password, nothing happended (actually, a new line
>> comes in, and I can enter some visible text). I had to Ctrl-C.
>> My goal is to automate this one in my post-commit hook of svn, in the
>> repository machine, so I can't enter password everytime.
>> Thanks in advance!
>> SVN version: 1.4.6 (auth with apache 2.2)
>> installed both ReviewBoard and RB-tools via easy_install, less than 1
>> week ago.
>> post-review --version gets 0.8
>> ReviewBoard is installed successfully at http://myrbserver, at least I
>> can login as admin and add users, groups etc, and has already added
>> the svn repository http://mysvnserver
>> - Rujia
> >

You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to