I'm about at my whits end for what I thought would be a very simple
task.  I have a Subversion server which can post to the ReviewBoard
server with post-review just fine when run from the command line - as
either root or apache (since SVN is accessed via Apache, post-commit
is run as Apache).

However, whenever I run it through the post-commit script it never
posts any reviews.  When I log the output from the call to "post-
review", this is what I get:

>>> svn info file:///var/svn/general
>>> diff --version
>>> repository info: Path: file:///var/svn/general, Base path: /, Supports 
>>> changesets: False
>>> Looking for 'review.energycap.com /' cookie in .post-review-cookies.txt
>>> Couldn't load cookie file: [Errno 2] No such file or directory: 
>>> '.post-review-cookies.txt'
==> Review Board Login Required
Enter username and password for Review Board at http://review.energycap.com/
>>> Logging in with username "ldapuser"
>>> HTTP POSTing to http://review.energycap.com/api/json/accounts/login/: 
>>> {'username': 'ldapuser', 'password': '**************'}

There appears to be something in the environment that is not allowing
this user to finish the login process - but I just can't figure it
out.  It appears that the script, when run this way, doesn't get the
Apache environment because it's looking for the cookie file in the
current directory - wherever the heck that is.  When I run it from the
command line, it tries to find that file in Apache (or roots) home
directory as expected.

That aside, it always stops at the "POSTing..." line.  So, either
something isn't available to this user when called or I'm totally
missing something obvious.

Anyone have any hints?  BTW - this post-commit hook is also calling a
Trac commit hook at the same time and works just fine.

I'd really appreciate the help.

Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to