On Jun 24, 9:12 pm, Dan Buch <daniel.b...@gmail.com> wrote:
> IIRC there's some naive logic in the remote Mercurial repo client inside
> Reviewboard that screws up the number/presence of some '/' chars.  I think
> a recently accepted patch fixed the logic, but you can get it working with
> older versions of ReviewBoard by doing something like this:
> for the "Path" value:
>    http://example.com/hgweb/AwesomeTown
> for the "Mirror path" value:
>    http://example.com/hgweb/AwesomeTown/
> And yes, it really is the trailing slash.  No, this is not 1994.

...Unbelievable.  Banging my head for days over a single slash (and no
documentation of the issue anywhere). Thank goodness there's a patch

I've submitted a documentation bug about this:

My prior solution had been to mount the repo itself from our repo
server via sshfs, but after putting the HTTPS URL back in minus the
trailing slash it still worked.  Thanks for that, because an
automounted sshfs was not exactly the greatest 'solution.'

> If you haven't already tried, I can warn you that the current public release
> of RBTools doesn't *actually* support plain ol' Mercurial usage, although it
> *does* have good support for hgsubversion.  Another recently-accepted patch
> fixes this (for the most part,) and a dist which includes it is available
> here:
>    http://github.com/meatballhat/rbtools/downloads

Thanks!  I will investigate that.  Any idea if it will be accepted

Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to