http://www.reviewboard.org/docs/manual/dev/users/tools/post-review/#reviewboardrc

On windows, I have it on each user's "%appdata%" folder.

On Tue, Jun 21, 2011 at 4:20 PM, ptrchen <ptrc...@gmail.com> wrote:
> Hi Leonel,
>
> Thanks for the reply, but where may I find .reviewboardrc?
>
> Thanks!
>
> Peter
>
> On Jun 20, 4:42 am, Leonel Togniolli <tognio...@gmail.com> wrote:
>> Hi ptrchen,
>>
>> I worked around this issue by adding two lines to .reviewboardrc
>>
>> import os
>> os.environ["no_proxy"] = "*"
>>
>> On Fri, Jun 17, 2011 at 7:48 PM, ptrchen <ptrc...@gmail.com> wrote:
>> > Hi Christian,
>>
>> > I think this page suggestions that should address my issues, correct?
>> >http://groups.google.com/group/reviewboard/browse_thread/thread/69e33...
>>
>> > On Jun 10, 4:54 pm, ptrchen <ptrc...@gmail.com> wrote:
>> >> Sorry Chrisitan, never mind, I misread your post. I'll do some more
>> >> digging for overriding the proxy configuration
>>
>> >> On Jun 10, 4:51 pm,ptrchen<ptrc...@gmail.com> wrote:
>>
>> >> > Ah, so would setting the environment variable in the command prompt
>> >> > window do the trick?
>>
>> >> > On Jun 10, 4:32 pm, Christian Hammond <chip...@chipx86.com> wrote:
>>
>> >> > > We've seen people run into this sort of error with proxy servers. 
>> >> > > Regardless
>> >> > > of your client-side proxy server configuration (say, in your Internet
>> >> > > settings, on Windows), it may still use the proxy server on 
>> >> > > post-review.
>>
>> >> > > The error output looks very much like it came from a proxy server, 
>> >> > > meaning
>> >> > > that the request is going out to the proxy, and the proxy can't find 
>> >> > > the
>> >> > > domain. You'll need to blacklist it. I don't recall if it will at all
>> >> > > respect this black list with Python running on Windows. If it's 
>> >> > > Linux, then
>> >> > > you want to be sure your http_proxy environment variable isn't set.
>>
>> >> > > This has come up a couple of times, and it's clear we need a setting 
>> >> > > in
>> >> > > post-review itself to just override the proxy configuration.
>>
>> >> > > If you search on this mailing list, you'll probably find a couple 
>> >> > > other
>> >> > > solutions.
>>
>> >> > > Christian
>>
>> >> > > --
>> >> > > Christian Hammond - chip...@chipx86.com
>> >> > > Review Board -http://www.reviewboard.org
>> >> > > VMware, Inc. -http://www.vmware.com
>>
>> >> > > On Fri, Jun 10, 2011 at 3:55 PM,ptrchen<ptrc...@gmail.com> wrote:
>> >> > > > Sorry for not listing all the output, but company policy prohibits 
>> >> > > > me
>> >> > > > from doing that.
>>
>> >> > > > Yes, the error lists the hostname and FQDN
>>
>> >> > > > Also, we do give it the FQDN following the --server option
>>
>> >> > > > On Jun 10, 2:56 pm, Tucker <j...@gmail.com> wrote:
>> >> > > > > Does the error actually only list the hostname and not the fully
>> >> > > > > qualified name?  If so, that may be part of your problem 
>> >> > > > > (throwing out
>> >> > > > > guesses).  Have you tried using the fully qualified name?
>>
>> >> > > > > On Fri, Jun 10, 2011 at 11:22 AM,ptrchen<ptrc...@gmail.com> wrote:
>> >> > > > > > Hi Tucker,
>>
>> >> > > > > > Thanks for the reply.
>>
>> >> > > > > > I ran "nslookup <server_name>" from both <server_name> (XP 
>> >> > > > > > server) and
>> >> > > > > > from a sparc-solaris2.10 machine.
>>
>> >> > > > > > Both return
>>
>> >> > > > > > Name:   <server_name>.<domain>
>> >> > > > > > Address: <ip_address>
>>
>> >> > > > > > On Jun 10, 11:15 am, Tucker <j...@gmail.com> wrote:
>> >> > > > > >> You appear to have a DNS problem:
>>
>> >> > > > > >> "Unable to determine IP address from host name for 
>> >> > > > > >> <server_name>."
>>
>> >> > > > > >> What does "nslookup <server_name>" say?
>>
>> >> > > > > >> On Thu, Jun 9, 2011 at 7:12 PM,ptrchen<ptrc...@gmail.com> 
>> >> > > > > >> wrote:
>> >> > > > > >> > Hi,
>>
>> >> > > > > >> > We've been trying to run post-review but have been running 
>> >> > > > > >> > into a
>> >> > > > > >> > "requested URL could not be retrieved" error
>>
>> >> > > > > >> > We're running:
>>
>> >> > > > > >> > ReviewBoard 1.5.5 on Windows XP
>> >> > > > > >> > Python 2.5.x
>> >> > > > > >> > Apache 2.2.x
>>
>> >> > > > > >> > Subversion 1.6.16, running on a sparc-solaris2.10
>>
>> >> > > > > >> > Here is the output after adding the --debug option:
>>
>> >> > > > --------------------------------------------------------------------------------------------------------------------------------------
>> >> > > > > >> > post-review --server=<server_name>/<rb_site> --username=**** 
>> >> > > > > >> > --
>> >> > > > > >> > password=******** --revision-range=8325 --debug
>> >> > > > > >> >>>> RBTools 0.3.2
>> >> > > > > >> >>>> Home = C:\Documents and Settings\****\Application Data
>> >> > > > > >> >>>> svn info
>> >> > > > > >> >>>> diff --version
>> >> > > > > >> >>>> repository info: Path: 
>> >> > > > > >> >>>> <svn-server>/<ParentPath>/<RepoName>, Base
>> >> > > > pa
>> >> > > > > >> > th: /trunk, Supports changesets: False
>> >> > > > > >> >>>> HTTP GETting api/
>> >> > > > > >> >>>> Got HTTP error: 503: <!DOCTYPE HTML PUBLIC "-//W3C//DTD 
>> >> > > > > >> >>>> HTML 4.01
>> >> > > > Transition
>> >> > > > > >> > al//EN" "http://www.w3.org/TR/html4/loose.dtd";>
>> >> > > > > >> > <HTML><HEAD><META HTTP-EQUIV="Content-Type" 
>> >> > > > > >> > CONTENT="text/html;
>> >> > > > > >> > charset=iso-8859
>> >> > > > > >> > -1">
>> >> > > > > >> > <TITLE>ERROR: The requested URL could not be 
>> >> > > > > >> > retrieved</TITLE>
>> >> > > > > >> > <STYLE 
>> >> > > > > >> > type="text/css"><!--BODY{background-color:#ffffff;font-
>> >> > > > > >> > family:verdana,san
>> >> > > > > >> > s-serif}PRE{font-family:sans-serif}--></STYLE>
>> >> > > > > >> > </HEAD><BODY>
>> >> > > > > >> > <H2>The requested URL could not be retrieved</H2>
>> >> > > > > >> > <HR noshade size="1px">
>> >> > > > > >> > <P>
>> >> > > > > >> > While trying to retrieve the URL:
>> >> > > > > >> > <A
>> >> > > > HREF="<server_name>/<rb_site>/api/"><server_name>/<rb_site>/api/</
>> >> > > > > >> > A>
>> >> > > > > >> > <P>
>> >> > > > > >> > The following error was encountered:
>> >> > > > > >> > <BLOCKQUOTE>
>> >> > > > > >> > Unable to determine IP address from host name for
>> >> > > > > >> > <I><server_name></I>
>> >> > > > > >> > </BLOCKQUOTE>
>>
>> >> > > > > >> > <P>
>> >> > > > > >> > The dnsserver returned:
>> >> > > > > >> > <BLOCKQUOTE>
>> >> > > > > >> > Name Error: The domain name does not exist.
>> >> > > > > >> > </BLOCKQUOTE>
>>
>> >> > > > > >> > <P>
>> >> > > > > >> > This means that:
>> >> > > > > >> > <PRE>
>> >> > > > > >> > The cache was not able to resolve the hostname presented in 
>> >> > > > > >> > the URL.
>> >> > > > > >> > Check if the address is correct.
>>
>> >> > > > --------------------------------------------------------------------------------------------------------------------------------------
>>
>> >> > > > > >> > Thanks!
>>
>> >> > > > > >> > --
>> >> > > > > >> > Want to help the Review Board project? Donate today athttp://
>> >> > > >www.reviewboard.org/donate/
>> >> > > > > >> > Happy user? Let us know athttp://www.reviewboard.org/users/
>> >> > > > > >> > -~----------~----~----~----~------~----~------~--~---
>> >> > > > > >> > To unsubscribe from this group, send email to
>> >> > > > reviewboard+unsubscr...@googlegroups.com
>> >> > > > > >> > For more options, visit this group athttp://
>> >> > > > groups.google.com/group/reviewboard?hl=en
>>
>> >> > > > > >> --
>>
>> >> > > > > >> --tucker
>>
>> >> > > > > > --
>> >> > > > > > Want to help the Review Board project? Donate today athttp://
>> >> > > >www.reviewboard.org/donate/
>> >> > > > > > Happy user? Let us know athttp://www.reviewboard.org/users/
>> >> > > > > > -~----------~----~----~----~------~----~------~--~---
>> >> > > > > > To unsubscribe from this group, send email to
>> >> > > > reviewboard+unsubscr...@googlegroups.com
>> >> > > > > > For more options, visit this group athttp://
>> >> > > > groups.google.com/group/reviewboard?hl=en
>>
>> >> > > > > --
>>
>> >> > > > > --tucker
>>
>> >> > > > --
>> >> > > > Want to help the Review Board project? Donate today at
>> >> > > >http://www.reviewboard.org/donate/
>> >> > > > Happy user? Let us know athttp://www.reviewboard.org/users/
>> >> > > > -~----------~----~----~----~------~----~------~--~---
>> >> > > > To unsubscribe from this group, send email to
>> >> > > > reviewboard+unsubscr...@googlegroups.com
>> >> > > > For more options, visit this group at
>> >> > > >http://groups.google.com/group/reviewboard?hl=en
>>
>> > --
>> > Want to help the Review Board project? Donate today 
>> > athttp://www.reviewboard.org/donate/
>> > Happy user? Let us know athttp://www.reviewboard.org/users/
>> > -~----------~----~----~----~------~----~------~--~---
>> > To unsubscribe from this group, send email to 
>> > reviewboard+unsubscr...@googlegroups.com
>> > For more options, visit this group 
>> > athttp://groups.google.com/group/reviewboard?hl=en
>
> --
> Want to help the Review Board project? Donate today at 
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to 
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at 
> http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to