today I tried to install ReviewBoard for the first time on one of our
companies servers (Apache on Ubuntu, MySQL and memcached). I'm a
developer and no system administrator, so it didn't come as a surprise
that id didn't work out of the box. At first mod_wsgi wasn't
installed, but that was easy to fix. But now, even an hour of googling
didn't help:

[Thu Mar 08 19:13:11 2012] [error] [client] mod_wsgi
(pid=8579): Target WSGI script '/home/www/review/htdocs/
reviewboard.wsgi' cannot be loaded as Python module.
[Thu Mar 08 19:13:11 2012] [error] [client] mod_wsgi
(pid=8579): Exception occurred processing WSGI script '/home/www/
[Thu Mar 08 19:13:11 2012] [error] [client] Traceback
(most recent call last):
[Thu Mar 08 19:13:11 2012] [error] [client]   File "/home/
www/review/htdocs/reviewboard.wsgi", line 11, in <module>
[Thu Mar 08 19:13:11 2012] [error] [client]     import
[Thu Mar 08 19:13:11 2012] [error] [client] ImportError:
No module named django.core.handlers.wsgi
[Thu Mar 08 19:13:11 2012] [error] [client] Symbolic link
not allowed or link target not accessible: /home/www/review/htdocs/

Any what could be the reason for this problem?

>From my googling, I think this could be a problem with a path or some
permissions, but as I'm normally a Windows user I have no idea where
and how to look). Maybe it's important that import django directly in
the python console only works if I'm root, not after "su - www-data".
And the sys.path is different as www-data, too. (You see, I tried
everything I found on the net ;)


Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to