We upgraded from 1.5.5 to 1.7.6 and I'm also seeing incorrect timestamps, 
even with new reviews.  I verified that our timezone is set to US/Pacific 
in Review Board general settings.  I just created a review at:

Tue Mar 26 11:47:57 PDT 2013

and it shows up in Review Board as 

Tue Mar 26 18:47:57 2013

which looks like UTC.


On Wednesday, March 20, 2013 10:15:23 AM UTC-7, David Lee wrote:
> This morning, I upgraded our ReviewBoard installation from 1.6.3 to 1.7.6, 
> and almost everything went smoothly.
> The only problem we've had with the upgrade is that the timestamps for 
> pre-upgrade reviews, comments, etc. are wrong. Timestamps for new content 
> are correct.
> I've set the Time Zone setting in Admin/General Settings, and I've set the 
> timezone for My Account as well. Prior to the upgrade, we also had 
> TIME_ZONE set in settings_local.py.
> We're using a MySQL database, with a Memcached cache backend, in case that 
> makes a difference.
> I've poked around on the database, and it looks as though with 1.6, 
> timestamps were being stored in local time, but now in 1.7 timestamps are 
> being stored in UTC.
> Are there any tools or scripts that someone can point me to for fixing the 
> timestamps in the database?
> Thanks!
> -- 
> David M. Lee
> Digium, Inc. | Software Developer
> 445 Jan Davis Drive NW - Huntsville, AL 35806 - USA
> Check us out at:  www.digium.com  & www.asterisk.org

Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to