Hi,

Update since last attempt :
Since I had problems upgrading from 1.6.3 to 1.7.7 , I setup a new virtual 
machine running Ubuntu 11.04 and installed ReviewBoard 1.7,7.1  ( the 
latest release ) and the reported problem of accessing CVS repository over 
ext still remains.

//Rahul

On Wednesday, April 24, 2013 6:14:23 PM UTC+5:30, Rahul Patil wrote:
>
> Hi Christian,
>
> No, nothing related to the attempted upgrade in reviewboard.log file.
> I will try what Stephen suggests, but can't attempt much time on R&D with 
> reviewboard down/in-operational, without someone complaining.
>
> /Rahul
>
> On Wednesday, April 24, 2013 1:57:59 AM UTC+5:30, Christian Hammond wrote:
>>
>> Was there anything in the reviewboard.log file? This doesn't sound like a 
>> database upgrade issue off-hand.
>>
>> Christian
>>
>>
>> On Apr 23, 2013, at 5:29, Rahul Patil <thes...@gmail.com> wrote:
>>
>> Hi Christian,
>>
>> Attempted to upgrade ReviewBoard to 1.7.7.1 and it messed up. 
>> Got this error when I hit the URL to RB site :
>>
>> Something broke! (Error 500) 
>>
>> It appears something broke when you tried to go to here. This is either a 
>> bug in Review Board or a server configuration error. Please report this to 
>> your administrator.
>>
>> Reverted to 1.6.3 for now, looks like I have to defer the upgrade since 
>> users are affected by unavailability of Reviewboard, so can't keep it at 
>> 1.7.7 and investigate the matter.
>>
>> Is it a known issue when upgrading from 1.6.x to 1.7.x ? If so, I will 
>> try 1.6.16.
>>
>>
>> regards,
>> Rahul
>>
>>
>> On Tuesday, April 23, 2013 11:03:29 AM UTC+5:30, Christian Hammond wrote:
>>>
>>> Hi Rahul,
>>>
>>> There have been quite a large number of SSH improvements and fixes for 
>>> rbssh since 1.6.3. At this point, 1.6.3 is considered ancient. It's worth 
>>> at least putting together a test 1.7.x installation and seeing if the 
>>> problem has been fixed.
>>>
>>> Christian
>>>
>>> -- 
>>> Christian Hammond - chi...@chipx86.com
>>> Review Board - http://www.reviewboard.org
>>> Beanbag, Inc. - http://www.beanbaginc.com
>>>  
>>> On Apr 22, 2013, at 10:10 PM, Rahul Patil <thes...@gmail.com> wrote:
>>>
>>> Hi Christian,
>>>
>>> I apologise if this thread in unsuitable to revive, please link me to 
>>> most recent chain if you know. This is the most relevant thread I could 
>>> find.
>>>
>>> I have the same issue, the setup is on Ubuntu 12.04 LTS , Reviewboard 
>>> version is 1.6.3. I try to create a new CVS repository with ext access and 
>>> it fails every time.
>>> I looked up the release notes of subsequent releases but could not 
>>> reliably gauge if the bug related to CVS ext/ssh access is fixed, so as 
>>> ascertain if upgrading will fix this. I tried the logging options in 
>>> rbssh.py file above in this thread, but I could not get detailed logging. 
>>> Enabled site logging and this is all I could get. None of the workarounds 
>>> resolve the problem either.
>>>
>>> In the browser, it displays error msg : 
>>>
>>>    - A repository was not found at the specified path.
>>>
>>>
>>> 2013-04-19 04:54:57,927 - DEBUG - starting thread (client mode): 
>>> 0x92729cd0L
>>> 2013-04-19 04:54:58,275 - INFO - Connected (version 2.0, client 
>>> OpenSSH_4.3)
>>> 2013-04-19 04:54:58,619 - DEBUG - kex 
>>> algos:['diffie-hellman-group-exchange-sha1', 'diffie-hellman-group14-sha1', 
>>> 'diffie-hellman-group1-sha1'] server key:['ssh-rsa', 'ssh-dss'] client 
>>> encrypt:['aes128-cbc', '3des-cbc', 'blowfish-cbc', 'cast128-cbc', 
>>> 'arcfour128', 'arcfour256', 'arcfour', 'aes192-cbc', 'aes256-cbc', 
>>> 'rijndael-cbc @ lysator.liu.se', 'aes128-ctr', 'aes192-ctr', 
>>> 'aes256-ctr'] server encrypt:['aes128-cbc', '3des-cbc', 'blowfish-cbc', 
>>> 'cast128-cbc', 'arcfour128', 'arcfour256', 'arcfour', 'aes192-cbc', 
>>> 'aes256-cbc', 'rijndael-cbc @ lysator.liu.se', 'aes128-ctr', 
>>> 'aes192-ctr', 'aes256-ctr'] client mac:['hmac-md5', 'hmac-sha1', 
>>> 'hmac-ripemd160', 'hmac-ripemd160 @openssh.com', 'hmac-sha1-96', 
>>> 'hmac-md5-96'] server mac:['hmac-md5', 'hmac-sha1', 'hmac-ripemd160', 
>>> 'hmac-ripemd160 @ openssh.com', 'hmac-sha1-96', 'hmac-md5-96'] client 
>>> compress:['none', 'zlib @ openssh.com'] server compress:['none', 'zlib 
>>> @ openssh.com'] client lang:[''] server lang:[''] kex follows?False
>>> 2013-04-19 04:54:58,619 - DEBUG - Ciphers agreed: local=aes128-ctr, 
>>> remote=aes128-ctr
>>> 2013-04-19 04:54:58,620 - DEBUG - using kex diffie-hellman-group1-sha1; 
>>> server key type ssh-rsa; cipher: local aes128-ctr, remote aes128-ctr; mac: 
>>> local hmac-sha1, remote hmac-sha1; compression: local none, remote none
>>> 2013-04-19 04:54:59,037 - DEBUG - Switch to new keys ...
>>> 2013-04-19 04:54:59,039 - DEBUG - Trying SSH key <keystring>
>>> 2013-04-19 04:54:59,787 - DEBUG - userauth is OK
>>> 2013-04-19 04:55:00,163 - INFO - Authentication (publickey) failed.
>>> 2013-04-19 04:55:00,174 - DEBUG - Trying discovered key <keystring> in 
>>> /home/reviewboard/mysite/data/.ssh/id_rsa
>>> 2013-04-19 04:55:00,517 - DEBUG - userauth is OK
>>> 2013-04-19 04:55:00,880 - INFO - Authentication (publickey) failed.
>>> 2013-04-19 04:55:01,227 - DEBUG - userauth is OK
>>> 2013-04-19 04:55:01,577 - INFO - Authentication (password) successful!
>>> 2013-04-19 04:55:01,678 - DEBUG - EOF in transport thread
>>>
>>> Apparently, it can authenticate against CVS but then fails ( to find 
>>> CVSROOT ? ). As I mentioned, I am not sure looking at release notes if 
>>> newer versions have resolved this, maybe you can clarify? If not, what 
>>> other changes can I try to get more detailed logging ( I'm not familiar 
>>> with Python, but willing to give it a shot if I need to change .py scripts 
>>> myself).
>>>
>>> thanks.
>>> Rahul
>>>
>>>
>>> On Thursday, March 10, 2011 1:58:52 AM UTC+5:30, Christian Hammond wrote:
>>>>
>>>> Hi Rob,
>>>>
>>>> Glad you got it working. I'll look into our repository path parsing 
>>>> code and see if we're somehow not handling the "\" in usernames. Maybe 
>>>> it's 
>>>> being stripped out somewhere.
>>>>
>>>> Christian
>>>>
>>>> -- 
>>>> Christian Hammond - chi...@chipx86.com
>>>> Review Board - http://www.reviewboard.org
>>>> VMware, Inc. - http://www.vmware.com
>>>>
>>>>
>>>> On Wed, Mar 9, 2011 at 4:11 AM, Rob Coward <r...@jive-videos.net>wrote:
>>>>
>>>>> FYI, I've got to the bottom of this with the help of the debug output. 
>>>>> It seems that whatever is calling rbssh is not picking up the Username 
>>>>> field and just passing the server component of the Path field. As a 
>>>>> result, 
>>>>> the rbssh script is calculating the username from the user running the 
>>>>> script (aka apache), and of course the remote server is denying access to 
>>>>> the incoming ssh session for apache.
>>>>>  
>>>>>
>>>>> By specifying the path as 
>>>>> ":ext:GROUP\lb...@svn.group.game.net:/app01/repository/cvs" 
>>>>> was also failing, as although rbssh was now getting the correct username, 
>>>>> it seems that something else was going awry in checking the validity of 
>>>>> the 
>>>>> CVS repository as it errored with "Unable to authenticate against this 
>>>>> repository using one of the supported authentication types."
>>>>>  
>>>>>
>>>>> The only way I got this to work was to specify the username both in 
>>>>> the path and in the Username fields. I also had to add "
>>>>> svn.group.game.net:/app01/repository/cvs/" in the Mirror field to 
>>>>> allow post-review to find the repository when posting diffs.
>>>>>
>>>>> Hope this helps anyone else with the same issue.
>>>>>
>>>>> Regards,
>>>>>
>>>>> Rob
>>>>>  
>>>>>
>>>>> On Fri, 4 Mar 2011 12:30:25 -0800, Christian Hammond wrote:
>>>>>
>>>>> Hi Rob,
>>>>>
>>>>> What OS/distro is in this on?
>>>>>
>>>>> Try finding rbssh.py in your reviewboard software installation dir 
>>>>> (reviewboard/cmdline/rbssh.py). Back up this file. We're going to make 
>>>>> some 
>>>>> modifications.
>>>>>
>>>>> Near the top there will be:
>>>>>
>>>>>     DEBUG = os.getenv('DEBUG_RBSSH')
>>>>>
>>>>> Change this to: DEBUG = True
>>>>>
>>>>> Further down, you'll find a line: logging.basicConfig(...). Should be 
>>>>> around line 237.
>>>>>
>>>>> Change the "filename='...'" to point to a writeable path 
>>>>> (/path/to/your/site/logs, or /tmp, or something).
>>>>>
>>>>> Then repeat your Add Repository, and check for that log file. Assuming 
>>>>> it was created, send it on to me privately and I'll see if anything 
>>>>> stands 
>>>>> out.
>>>>>
>>>>> Christian
>>>>>
>>>>>
>>>>> -- 
>>>>> Christian Hammond - chi...@chipx86.com
>>>>> Review Board - http://www.reviewboard.org
>>>>> VMware, Inc. - http://www.vmware.com
>>>>>
>>>>>
>>>>> On Fri, Mar 4, 2011 at 8:33 AM, RobC <r...@jive-videos.net> wrote:
>>>>>
>>>>>> I've just installed a new reviewboard server with 1.6 beta1 and am
>>>>>> hitting the same issue. Anyone got any news on this ?
>>>>>>
>>>>>> Thanks,
>>>>>> Rob
>>>>>>  
>>>>>> --
>>>>>> Want to help the Review Board project? Donate today at 
>>>>>> http://www.reviewboard.org/donate/
>>>>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>>>>> -~----------~----~----~----~------~----~------~--~---
>>>>>> To unsubscribe from this group, send email to 
>>>>>> reviewboard...@googlegroups.com
>>>>>> For more options, visit this group at 
>>>>>> http://groups.google.com/group/reviewboard?hl=en
>>>>>>  
>>>>>  
>>>>>  
>>>>> -- 
>>>>> Want to help the Review Board project? Donate today at 
>>>>> http://www.reviewboard.org/donate/
>>>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>>>> -~----------~----~----~----~------~----~------~--~---
>>>>> To unsubscribe from this group, send email to 
>>>>> reviewboard...@googlegroups.com
>>>>> For more options, visit this group at 
>>>>> http://groups.google.com/group/reviewboard?hl=en
>>>>>
>>>>>
>>>>> -- 
>>>>> Want to help the Review Board project? Donate today at 
>>>>> http://www.reviewboard.org/donate/
>>>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>>>> -~----------~----~----~----~------~----~------~--~---
>>>>> To unsubscribe from this group, send email to 
>>>>> reviewboard...@googlegroups.com
>>>>> For more options, visit this group at 
>>>>> http://groups.google.com/group/reviewboard?hl=en
>>>>>
>>>>
>>>>
>>> -- 
>>> Want to help the Review Board project? Donate today at 
>>> http://www.reviewboard.org/donate/
>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>> -~----------~----~----~----~------~----~------~--~---
>>> To unsubscribe from this group, send email to 
>>> reviewboard...@googlegroups.com
>>> For more options, visit this group at 
>>> http://groups.google.com/group/reviewboard?hl=en
>>> --- 
>>> You received this message because you are subscribed to the Google 
>>> Groups "reviewboard" group.
>>> To unsubscribe from this group and stop receiving emails from it, send 
>>> an email to reviewboard...@googlegroups.com.
>>> For more options, visit https://groups.google.com/groups/opt_out.
>>>  
>>>  
>>>
>>>
>>>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to