RBTools 0.5.6 solved this problem. Thanks guys!
Karl

On Wednesday, 29 January 2014 15:01:57 UTC-8, Karl Nordstrom wrote:
>
> Excellent! Thanks!
>
> Karl
>
> On Wednesday, 29 January 2014 14:56:12 UTC-8, David Trowbridge wrote:
>>
>> Karl,
>>
>> We'll try to get it done in the next day or two.
>>
>> -David
>>
>>
>> On Wed, Jan 29, 2014 at 2:54 PM, Karl Nordstrom <north...@gmail.com>wrote:
>>
>>> Thank you Christian and David,
>>>
>>> Do you have an approximate sense of how long it might be before 0.5.6 
>>> comes out?
>>>
>>> Thanks,
>>> Karl
>>>
>>>
>>> On Wednesday, 29 January 2014 14:23:11 UTC-8, David Trowbridge wrote:
>>>
>>>> Karl,
>>>>
>>>> This is an rbtools bug. We'll get it fixed for 0.5.6.
>>>>
>>>> Thanks,
>>>> -David
>>>>
>>>>
>>>> On Wed, Jan 29, 2014 at 1:37 PM, Karl Nordstrom <north...@gmail.com>wrote:
>>>>
>>>>> I am trying to post a review from perforce to ReviewBoard using rbt 
>>>>> diff, but I am getting an error: AttributeError: Values instance has no 
>>>>> attribute 'p4_client'
>>>>>
>>>>> My p4config file is as follows:
>>>>>
>>>>> P4PORT=stork:1666
>>>>> P4USER=knordstrom
>>>>> P4CLIENT=knordstrom_passenger
>>>>>
>>>>> I'm pretty sure that this is correct because I can do "p4 diff" on the 
>>>>> commandline and get a meaningful diff. Unfortunately, perforce does not 
>>>>> create the diff in GNU format, so I have to use rbt.
>>>>>
>>>>> My .reviewboardrc contains the following entry, which is the location 
>>>>> of the reviewboard server that I have setup:
>>>>>
>>>>> REVIEWBOARD_URL = "http://192.168.1.28";
>>>>>
>>>>> When run "rbt diff -d" I get the following output:
>>>>>
>>>>> DEBUG:root:Checking for a Subversion repository...
>>>>> DEBUG:root:Checking for a Git repository...
>>>>> DEBUG:root:Checking for a Mercurial repository...
>>>>> DEBUG:root:Checking for a CVS repository...
>>>>> DEBUG:root:Checking for a Perforce repository...
>>>>> DEBUG:root:Running: p4 info
>>>>> DEBUG:root:Running: diff --version
>>>>> DEBUG:root:repository info: Path: stork.questercorp.local:1666, Base 
>>>>> path: None, Supports changesets: True
>>>>> DEBUG:root:Making HTTP GET request to http://192.168.1.28/api/
>>>>> DEBUG:root:Making HTTP GET request to http://192.168.1.28/api/info/
>>>>> Traceback (most recent call last):
>>>>>   File "C:\Python27\Scripts\rbt-script.py", line 9, in <module>
>>>>>     load_entry_point('RBTools==0.5.5', 'console_scripts', 'rbt')()
>>>>>   File 
>>>>> "C:\Python27\lib\site-packages\rbtools-0.5.5-py2.7.egg\rbtools\commands\main.py",
>>>>>  
>>>>> line 127, in main
>>>>>     command.run_from_argv([RB_MAIN] + args)
>>>>>   File "C:\Python27\lib\site-packages\rbtools-0.5.5-py2.7.
>>>>> egg\rbtools\commands\__init__.py", line 158, in run_from_argv
>>>>>     exit_code = self.main(*args) or 0
>>>>>   File 
>>>>> "C:\Python27\lib\site-packages\rbtools-0.5.5-py2.7.egg\rbtools\commands\diff.py",
>>>>>  
>>>>> line 95, in main
>>>>>     files=args)
>>>>>   File 
>>>>> "C:\Python27\lib\site-packages\rbtools-0.5.5-py2.7.egg\rbtools\utils\diffs.py",
>>>>>  
>>>>> line 17, in get_diff
>>>>>     diff_info = scmtool.diff(files)
>>>>>   File "C:\Python27\lib\site-packages\rbtools-0.5.5-py2.7.
>>>>> egg\rbtools\clients\perforce.py", line 293, in diff
>>>>>     if self.options.p4_client:
>>>>>  AttributeError: Values instance has no attribute 'p4_client'
>>>>>
>>>>> Is there an existing solution to this problem? If so, please give me 
>>>>> enough info to fix it.
>>>>>
>>>>> Is this a bug in RBTools code?
>>>>>
>>>>> Thanks in advance for your help,
>>>>> Karl
>>>>>
>>>>> -- 
>>>>> Get the Review Board Power Pack at http://www.reviewboard.org/
>>>>> powerpack/
>>>>> ---
>>>>> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
>>>>> ---
>>>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>>>> --- 
>>>>> You received this message because you are subscribed to the Google 
>>>>> Groups "reviewboard" group.
>>>>> To unsubscribe from this group and stop receiving emails from it, send 
>>>>> an email to reviewboard...@googlegroups.com.
>>>>>
>>>>> For more options, visit https://groups.google.com/groups/opt_out.
>>>>>
>>>>
>>>>  -- 
>>> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
>>> ---
>>> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
>>> ---
>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>> --- 
>>> You received this message because you are subscribed to the Google 
>>> Groups "reviewboard" group.
>>> To unsubscribe from this group and stop receiving emails from it, send 
>>> an email to reviewboard...@googlegroups.com.
>>> For more options, visit https://groups.google.com/groups/opt_out.
>>>
>>
>>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to