We are using ClearCase with ReviewBoard (version 1.7) on Windows XP. 
rbttool version is 0.5.6.

I have created a view and mount it on "T:" drive. My Reviewboard server is 
running on PC itself.
When I tried to raise a Review request from T:, I am getting the below 
error at rbt tool side.

T:\mayankk_view\bse_tdscdma_fw_app_l3>rbt post -d
DEBUG:root:Checking for a Subversion repository...
DEBUG:root:Checking for a Git repository...
DEBUG:root:Checking for a Mercurial repository...
DEBUG:root:Checking for a CVS repository...
DEBUG:root:Checking for a Perforce repository...
DEBUG:root:Checking for a Plastic repository...
DEBUG:root:Checking for a ClearCase repository...
DEBUG:root:Running: cleartool pwv -short
DEBUG:root:Running: diff --version
DEBUG:root:Running: cleartool lsview -full -properties -cview
DEBUG:root:Running: cleartool describe -short vob:.
DEBUG:root:Running: cleartool pwv -root
DEBUG:root:repository info: Path: T:\mayankk_view\bse_tdscdma_fw_app_l3, 
Base path: T:\mayankk_view\bse_tdscdma_fw_app_l3, Supports changesets: False
DEBUG:root:Making HTTP GET request to
DEBUG:root:Making HTTP GET request to
DEBUG:root:Running: cleartool lscheckout -all -cview -me -fmt 
DEBUG:root:Running: cleartool get -to 
DEBUG:root:Running: cleartool get -to 
DEBUG:root:Running: diff -uN c:\docume~1\mayankk\locals~1\temp\tmpt2cgxz 
DEBUG:root:Command exited with rc 1: ['diff', '-uN', 
--- c:\docume~1\mayankk\locals~1\temp\tmpt2cgxz 2014-02-28 
17:53:29.502049100 +0530
+++ c:\docume~1\mayankk\locals~1\temp\tmpflocin 2014-02-28 
17:53:29.673915300 +0530
@@ -16,7 +16,7 @@
 * DESCRIPTION:   This file contains the member functions for 
CommandHandler class
-//Comment added by mayank for testing
+//Comment added by mayank for
 #include "CommandHandler.h"
 #include <map>
 using namespace std;
DEBUG:root:Running: cleartool describe -fmt %On 
DEBUG:root:Running: cleartool describe -fmt %On 
DEBUG:root:Making HTTP GET request to
DEBUG:root:Making HTTP POST request to
DEBUG:root:Making HTTP GET request to
DEBUG:root:Making HTTP POST request to
DEBUG:root:Got API Error 207 (HTTP code 400): The file was not found in the 
DEBUG:root:Error data: {u'stat': u'fail', u'file': 
u'err': {u'msg': u'The file was not found in the repository', u'
code': 207}, u'revision': 
Traceback (most recent call last):
  File "C:\Python27\Scripts\rbt-script.py", line 8, in <module>
    load_entry_point('RBTools==0.5.6', 'console_scripts', 'rbt')()
line 127, in main
    command.run_from_argv([RB_MAIN] + args)
line 158, in run_from_argv
    exit_code = self.main(*args) or 0
line 659, in main
line 534, in post_request
    raise CommandError('\n'.join(error_msg))
rbtools.commands.CommandError: Error uploading diff

The file was not found in the repository (HTTP 400, API Error 207)
Your review request still exists, but the diff is not attached.

If I execute it from M: (dynamic view) or local harddisk (snapshot view), 
then it works fine.

I did some trouble shooting with my limited knowledge of Phython and came 
to know that in clearcase.py, script is not able to access network drive.
Till now I tried the below:
1. Created a small Phython program with the same code as in clearcase.py 
and executed it manually. It works fine. It means that using Phython I am 
able to access network drive.
2. Checked the user name by which Apache server is running. Changed it to 
my user (which has all the admin rights) but still its not working.
3. Checked with Dynamic and Static view with network drive. Getting the 
similar issue.

Did anyone faced the same issue??
Is there any setting I am missing because of which when script is executed 
via Apache, its not able to access network drive??

Would appreciate any help/support or pointer.


Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
Happy user? Let us know at http://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to